summaryrefslogtreecommitdiffstats
path: root/abs/chroot-devel/terminal
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-10-04 04:07:38 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-10-04 04:07:38 (GMT)
commitdb40f2ab304cc32d9a69ee215727c8663b757c53 (patch)
tree02437908944190186e1ab040fcf5f13c80fbc316 /abs/chroot-devel/terminal
parentea26ba87276362ba1e99ececcb9e802ab2bd8776 (diff)
downloadlinhes_pkgbuild-db40f2ab304cc32d9a69ee215727c8663b757c53.zip
linhes_pkgbuild-db40f2ab304cc32d9a69ee215727c8663b757c53.tar.gz
linhes_pkgbuild-db40f2ab304cc32d9a69ee215727c8663b757c53.tar.bz2
adding tools for chroot-devel
Diffstat (limited to 'abs/chroot-devel/terminal')
-rw-r--r--abs/chroot-devel/terminal/PKGBUILD25
-rw-r--r--abs/chroot-devel/terminal/terminal-dont-die-on-dbus-kill.patch10
-rw-r--r--abs/chroot-devel/terminal/terminal.install11
3 files changed, 46 insertions, 0 deletions
diff --git a/abs/chroot-devel/terminal/PKGBUILD b/abs/chroot-devel/terminal/PKGBUILD
new file mode 100644
index 0000000..9f17eee
--- /dev/null
+++ b/abs/chroot-devel/terminal/PKGBUILD
@@ -0,0 +1,25 @@
+
+pkgname=terminal
+pkgver=0.2.8
+pkgrel=3
+pkgdesc="A modern terminal emulator primarly for the Xfce desktop environment"
+arch=(i686 x86_64)
+license=('GPL2')
+url="http://www.xfce.org/projects/terminal/"
+groups=('xfce4')
+depends=('exo>=0.3.4' 'vte>=0.16.14' 'dbus-glib>=0.76'
+ 'hicolor-icon-theme')
+makedepends=('pkgconfig')
+options=('!libtool')
+install=terminal.install
+source=(http://www.xfce.org/archive/xfce-4.4.2/src/Terminal-${pkgver}.tar.bz2
+ terminal-dont-die-on-dbus-kill.patch)
+
+build() {
+ cd ${srcdir}/Terminal-${pkgver}
+ patch -Np0 -i ${srcdir}/terminal-dont-die-on-dbus-kill.patch || return 1
+ ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib/xfce4 \
+ --localstatedir=/var --disable-static || return 1
+ make || return 1
+ make DESTDIR=${pkgdir} install || return 1
+}
diff --git a/abs/chroot-devel/terminal/terminal-dont-die-on-dbus-kill.patch b/abs/chroot-devel/terminal/terminal-dont-die-on-dbus-kill.patch
new file mode 100644
index 0000000..e20e45c
--- /dev/null
+++ b/abs/chroot-devel/terminal/terminal-dont-die-on-dbus-kill.patch
@@ -0,0 +1,10 @@
+--- terminal/terminal-dbus.c.orig 2007-01-23 22:25:12.000000000 +0000
++++ terminal/terminal-dbus.c 2007-01-23 22:25:50.000000000 +0000
+@@ -191,6 +191,7 @@ terminal_dbus_register_service (Terminal
+
+ /* register DBus connection with GLib main loop */
+ dbus_connection_setup_with_g_main (connection, NULL);
++ dbus_connection_set_exit_on_disconnect (connection, FALSE);
+
+ if (dbus_bus_request_name (connection, TERMINAL_DBUS_SERVICE, 0, &derror) < 0)
+ {
diff --git a/abs/chroot-devel/terminal/terminal.install b/abs/chroot-devel/terminal/terminal.install
new file mode 100644
index 0000000..21b79d2
--- /dev/null
+++ b/abs/chroot-devel/terminal/terminal.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}