summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/LinHES-config-svn/LinHES.install
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-03-05 14:03:43 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-03-05 14:03:43 (GMT)
commitd6049e8a38b8babf070b6f2183c336334ed97fd9 (patch)
tree02d056dad35316a7300df7881d73a12fc739cca0 /abs/core-testing/LinHES-config-svn/LinHES.install
parent3cbdc98e4cf54f67c9e02c960779ea8c93886646 (diff)
parent02ac0e14081290faebfd699fb4f5e61f726d38ef (diff)
downloadlinhes_pkgbuild-d6049e8a38b8babf070b6f2183c336334ed97fd9.zip
linhes_pkgbuild-d6049e8a38b8babf070b6f2183c336334ed97fd9.tar.gz
linhes_pkgbuild-d6049e8a38b8babf070b6f2183c336334ed97fd9.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD.git
Diffstat (limited to 'abs/core-testing/LinHES-config-svn/LinHES.install')
-rw-r--r--abs/core-testing/LinHES-config-svn/LinHES.install78
1 files changed, 78 insertions, 0 deletions
diff --git a/abs/core-testing/LinHES-config-svn/LinHES.install b/abs/core-testing/LinHES-config-svn/LinHES.install
new file mode 100644
index 0000000..a0a9d31
--- /dev/null
+++ b/abs/core-testing/LinHES-config-svn/LinHES.install
@@ -0,0 +1,78 @@
+# This is a default template for a post-install scriptlet. You can
+# remove any functions you don't need (and this header).
+
+# arg 1: the new package version
+pre_install() {
+ rm -f /etc/issue
+ rm -f /etc/arch-release
+
+}
+
+# arg 1: the new package version
+post_install() {
+ if [ ! -f /etc/blacklist.package ]
+ then
+ echo "List of packages to ignore" > /etc/blacklist.package
+ echo "one package per line" >> /etc/blacklist.package
+ fi
+
+LINE="mythtv ALL = NOPASSWD:/usr/MythVantage/bin/mythvantage"
+LINE1="mythtv ALL = NOPASSWD:/usr/MythVantage/bin/MythVantage"
+for i in "$LINE" "$LINE1"
+do
+ cp /etc/sudoers /etc/sudoers.bak
+ grep -q "$i" /etc/sudoers
+ if [ $? != 0 ]
+ then
+ echo "$i" >> /etc/sudoers
+ visudo -cf /etc/sudoers
+ if [ ! $? = 0 ]
+ then
+ cp /etc/sudoers.bak /etc/sudoers
+ echo $i
+ echo "Error adding files"
+ exit 1
+ fi
+ fi
+done
+
+
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+pre_upgrade() {
+ /bin/true
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ . /etc/profile
+ ps -ef|grep mysqld|grep -v grep
+ status=$?
+ echo "status $status"
+ if [ $status = 0 ]
+ then
+ restore_default_settings.sh -c load
+ fi
+ if [ ! -f /etc/blacklist.package ]
+ then
+ echo "List of packages to ignore" > /etc/blacklist.package
+ echo "one package per line" >> /etc/blacklist.package
+ fi
+}
+
+# arg 1: the old package version
+pre_remove() {
+ /bin/true
+}
+
+# arg 1: the old package version
+post_remove() {
+ /bin/true
+}
+
+op=$1
+shift
+$op $*