summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/LinHES-config-svn/live-install.sh
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-03-05 14:03:43 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-03-05 14:03:43 (GMT)
commitd6049e8a38b8babf070b6f2183c336334ed97fd9 (patch)
tree02d056dad35316a7300df7881d73a12fc739cca0 /abs/core-testing/LinHES-config-svn/live-install.sh
parent3cbdc98e4cf54f67c9e02c960779ea8c93886646 (diff)
parent02ac0e14081290faebfd699fb4f5e61f726d38ef (diff)
downloadlinhes_pkgbuild-d6049e8a38b8babf070b6f2183c336334ed97fd9.zip
linhes_pkgbuild-d6049e8a38b8babf070b6f2183c336334ed97fd9.tar.gz
linhes_pkgbuild-d6049e8a38b8babf070b6f2183c336334ed97fd9.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD.git
Diffstat (limited to 'abs/core-testing/LinHES-config-svn/live-install.sh')
-rwxr-xr-xabs/core-testing/LinHES-config-svn/live-install.sh28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/core-testing/LinHES-config-svn/live-install.sh b/abs/core-testing/LinHES-config-svn/live-install.sh
new file mode 100755
index 0000000..573bb1f
--- /dev/null
+++ b/abs/core-testing/LinHES-config-svn/live-install.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+#redirect stderr to stdout, then rediret stdout to file
+. /etc/profile
+exec 2>&1
+exec > /tmp/mythvantage_install.log
+. /etc/X11/STBWINDOWMANAGER
+/usr/bin/nvidia-settings -a InitialPixmapPlacement=2
+keylaunch &
+/usr/bin/tilda &
+/usr/X11R6/bin/unclutter -root -idle 0 -jitter 400 -noevents &
+export MALLOC_CHECK_=0
+if [ -f /opt/vmware/bin32/vmware-user-wrapper ]
+then
+ /opt/vmware/bin32/vmware-user-wrapper &
+fi
+xhost +
+CMDLINE=$(cat /proc/cmdline)
+echo $CMDLINE |grep -q nfsroot
+NFSROOT=$?
+if [ x$NFSROOT = x1 ]
+then
+
+ unbuffer MythVantage &
+else
+ NETBOOT=YES MythVantage &
+fi
+
+exec $STBWINDOWMANAGER