summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/LinHES-config-svn/startx
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-03-05 14:03:43 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-03-05 14:03:43 (GMT)
commitd6049e8a38b8babf070b6f2183c336334ed97fd9 (patch)
tree02d056dad35316a7300df7881d73a12fc739cca0 /abs/core-testing/LinHES-config-svn/startx
parent3cbdc98e4cf54f67c9e02c960779ea8c93886646 (diff)
parent02ac0e14081290faebfd699fb4f5e61f726d38ef (diff)
downloadlinhes_pkgbuild-d6049e8a38b8babf070b6f2183c336334ed97fd9.zip
linhes_pkgbuild-d6049e8a38b8babf070b6f2183c336334ed97fd9.tar.gz
linhes_pkgbuild-d6049e8a38b8babf070b6f2183c336334ed97fd9.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD.git
Diffstat (limited to 'abs/core-testing/LinHES-config-svn/startx')
-rwxr-xr-xabs/core-testing/LinHES-config-svn/startx29
1 files changed, 29 insertions, 0 deletions
diff --git a/abs/core-testing/LinHES-config-svn/startx b/abs/core-testing/LinHES-config-svn/startx
new file mode 100755
index 0000000..0ffdf8c
--- /dev/null
+++ b/abs/core-testing/LinHES-config-svn/startx
@@ -0,0 +1,29 @@
+#!/bin/bash
+. /etc/profile
+
+export USER=root
+export HOME=/root
+#TEMPLATES=/usr/share/templates
+
+CMDLINE=$(cat /proc/cmdline)
+TEMPVAR=${CMDLINE#*ip=}
+IP=${TEMPVAR%% *}
+echo $CMDLINE |grep -q vnc
+USEVNC=$?
+
+if [ x$USEVNC = x1 ]
+then
+ $MV_ROOT/bin/xconfig.sh
+ cat /etc/X11/xorg.conf | sed -e 's/dev\/mouse/dev\/psaux/g'> /root/xorg.conf.install
+ startx /root/live-install.sh -- -config /root/xorg.conf.install -allowMouseOpenFail
+ else
+ #VNC
+ pacman -Sf --noconfirm tightvnc
+ cd /root
+ mkdir .vnc
+ echo mythvantage |vncpasswd -f > /root/.vnc/passwd
+ chmod 500 /root/.vnc/passwd
+ rm /root/.vnc/xstartup
+ ln -s /root/live-install.sh /root/.vnc/xstartup
+ vncserver
+fi