summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/LinHES-config/mv_software.py
diff options
context:
space:
mode:
authorGreg Frost <gregfrost1@bigpond.com>2009-08-28 09:08:13 (GMT)
committerGreg Frost <gregfrost1@bigpond.com>2009-08-28 09:08:13 (GMT)
commit428e5178d79eb900bbe515665b2d6c6a4b0d0f89 (patch)
tree5cf7c10428f1d0afe62eeee70105bd447ea69b99 /abs/core-testing/LinHES-config/mv_software.py
parentf6276f03790fc2302054a8242339def7b6792557 (diff)
parent568da1387066e54f0eceb57fd8f53bd0eba87974 (diff)
downloadlinhes_pkgbuild-428e5178d79eb900bbe515665b2d6c6a4b0d0f89.zip
linhes_pkgbuild-428e5178d79eb900bbe515665b2d6c6a4b0d0f89.tar.gz
linhes_pkgbuild-428e5178d79eb900bbe515665b2d6c6a4b0d0f89.tar.bz2
Merge branch 'master' of ssh://gregfrost@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/LinHES-config/mv_software.py')
-rwxr-xr-xabs/core-testing/LinHES-config/mv_software.py38
1 files changed, 28 insertions, 10 deletions
diff --git a/abs/core-testing/LinHES-config/mv_software.py b/abs/core-testing/LinHES-config/mv_software.py
index e5b96b2..7421e08 100755
--- a/abs/core-testing/LinHES-config/mv_software.py
+++ b/abs/core-testing/LinHES-config/mv_software.py
@@ -4,29 +4,47 @@ import os, re
def setup_software(systemconfig, data_config):
logging.info("____Start of Software install____")
- default_disabled = ("mythphone", "mytharchive", "mythbrowser", "mythnews",
- "mythgame", "mythflix", "mythweather",
- "mythappletrailers", "mythstream", "mythvodka")
+ postfix=''
+ if data_config.SYSTEMTYPE == "MythVantage":
+ #look for the installed prefix
+ cmd="pacman -Q mythtv-release-fixes"
+ rc = mv_common.runcmd(cmd)
+ if rc == 0:
+ postfix = "-release-fixes"
+ else:
+ postfix = "-svn"
- default_installed=("mythcontrols", "mythgallery", "mythmovies",
- "mythmusic", "mythsmolt", "mythvideo")
- other_pkg=("miro", "xe", "romdb", "xine", "dvdcss", "webmin" , "fuppes")
+ default_disabled = ("mythphone", "mytharchive", "mythbrowser", "mythnews",
+ "mythgame", "mythflix", "mythweather" )
+
+ default_installed=("mythcontrols", "mythgallery", "mythmovies",
+ "mythmusic", "mythsmolt", "mythvideo")
+ other_pkg=("miro", "xe", "romdb", "xine", "dvdcss", "webmin" , "fuppes", "mythappletrailers", "mythstream", "mythvodka")
+ else:
+ default_disabled = ("mythphone", "mytharchive", "mythbrowser", "mythnews",
+ "mythgame", "mythflix", "mythweather",
+ "mythappletrailers", "mythstream", "mythvodka")
+
+ default_installed=("mythcontrols", "mythgallery", "mythmovies",
+ "mythmusic", "mythsmolt", "mythvideo")
+ other_pkg=("miro", "xe", "romdb", "xine", "dvdcss", "webmin" , "fuppes")
for pkg in default_disabled:
+ pkgname=pkg+postfix
try:
if systemconfig[pkg] == "1":
- mv_common.pacinstall(pkg)
+ mv_common.pacinstall(pkgname)
else:
- mv_common.pacremove(pkg)
+ mv_common.pacremove(pkgname)
except:
logging.debug(" ERROR-- %s is not defined", pkg)
for pkg in default_installed:
try:
if systemconfig[pkg] == "0":
- mv_common.pacremove(pkg)
+ mv_common.pacremove(pkgname)
else:
- mv_common.pacinstall(pkg)
+ mv_common.pacinstall(pkgname)
except:
logging.debug(" ERROR-- %s is not defined", pkg)