summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/LinHES-config/mv_software.py
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-08-22 00:27:53 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-08-22 00:27:53 (GMT)
commitdb17e125c87e8056e2d0cdc5f1985ab62e713c84 (patch)
tree0e2c84550d6ffdfd33cc84c12c396db9ce3c987b /abs/core-testing/LinHES-config/mv_software.py
parente067093b13fb71f9d928ccf7a1b3ce6dd0124795 (diff)
parentd630a6ae3ada088453209270791ae281e2d5e393 (diff)
downloadlinhes_pkgbuild-db17e125c87e8056e2d0cdc5f1985ab62e713c84.zip
linhes_pkgbuild-db17e125c87e8056e2d0cdc5f1985ab62e713c84.tar.gz
linhes_pkgbuild-db17e125c87e8056e2d0cdc5f1985ab62e713c84.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/LinHES-config/mv_software.py')
-rwxr-xr-xabs/core-testing/LinHES-config/mv_software.py38
1 files changed, 28 insertions, 10 deletions
diff --git a/abs/core-testing/LinHES-config/mv_software.py b/abs/core-testing/LinHES-config/mv_software.py
index e5b96b2..7421e08 100755
--- a/abs/core-testing/LinHES-config/mv_software.py
+++ b/abs/core-testing/LinHES-config/mv_software.py
@@ -4,29 +4,47 @@ import os, re
def setup_software(systemconfig, data_config):
logging.info("____Start of Software install____")
- default_disabled = ("mythphone", "mytharchive", "mythbrowser", "mythnews",
- "mythgame", "mythflix", "mythweather",
- "mythappletrailers", "mythstream", "mythvodka")
+ postfix=''
+ if data_config.SYSTEMTYPE == "MythVantage":
+ #look for the installed prefix
+ cmd="pacman -Q mythtv-release-fixes"
+ rc = mv_common.runcmd(cmd)
+ if rc == 0:
+ postfix = "-release-fixes"
+ else:
+ postfix = "-svn"
- default_installed=("mythcontrols", "mythgallery", "mythmovies",
- "mythmusic", "mythsmolt", "mythvideo")
- other_pkg=("miro", "xe", "romdb", "xine", "dvdcss", "webmin" , "fuppes")
+ default_disabled = ("mythphone", "mytharchive", "mythbrowser", "mythnews",
+ "mythgame", "mythflix", "mythweather" )
+
+ default_installed=("mythcontrols", "mythgallery", "mythmovies",
+ "mythmusic", "mythsmolt", "mythvideo")
+ other_pkg=("miro", "xe", "romdb", "xine", "dvdcss", "webmin" , "fuppes", "mythappletrailers", "mythstream", "mythvodka")
+ else:
+ default_disabled = ("mythphone", "mytharchive", "mythbrowser", "mythnews",
+ "mythgame", "mythflix", "mythweather",
+ "mythappletrailers", "mythstream", "mythvodka")
+
+ default_installed=("mythcontrols", "mythgallery", "mythmovies",
+ "mythmusic", "mythsmolt", "mythvideo")
+ other_pkg=("miro", "xe", "romdb", "xine", "dvdcss", "webmin" , "fuppes")
for pkg in default_disabled:
+ pkgname=pkg+postfix
try:
if systemconfig[pkg] == "1":
- mv_common.pacinstall(pkg)
+ mv_common.pacinstall(pkgname)
else:
- mv_common.pacremove(pkg)
+ mv_common.pacremove(pkgname)
except:
logging.debug(" ERROR-- %s is not defined", pkg)
for pkg in default_installed:
try:
if systemconfig[pkg] == "0":
- mv_common.pacremove(pkg)
+ mv_common.pacremove(pkgname)
else:
- mv_common.pacinstall(pkg)
+ mv_common.pacinstall(pkgname)
except:
logging.debug(" ERROR-- %s is not defined", pkg)