summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/LinHES-config/systemconfig.py
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-06-22 14:51:34 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-06-22 14:51:34 (GMT)
commit7261f38f4e32ab918f5ebf8c5f5fe6e807c145ba (patch)
tree1b3cdb98bd3394bdb09d3b779baf56a57f3a7778 /abs/core-testing/LinHES-config/systemconfig.py
parent52453cb0e266095b08f896c20fa86a0be0dbfc6d (diff)
parent71f2f52cdb80bb814fde97b994e1625beac55282 (diff)
downloadlinhes_pkgbuild-7261f38f4e32ab918f5ebf8c5f5fe6e807c145ba.zip
linhes_pkgbuild-7261f38f4e32ab918f5ebf8c5f5fe6e807c145ba.tar.gz
linhes_pkgbuild-7261f38f4e32ab918f5ebf8c5f5fe6e807c145ba.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/LinHES-config/systemconfig.py')
-rwxr-xr-xabs/core-testing/LinHES-config/systemconfig.py7
1 files changed, 5 insertions, 2 deletions
diff --git a/abs/core-testing/LinHES-config/systemconfig.py b/abs/core-testing/LinHES-config/systemconfig.py
index 5ccaa10..4d69a1f 100755
--- a/abs/core-testing/LinHES-config/systemconfig.py
+++ b/abs/core-testing/LinHES-config/systemconfig.py
@@ -100,7 +100,10 @@ def main(argv):
cmdmodule["smolt"] = True
if cmdmodule["network"]:
- mv_network.setup_network(systemconfig)
+ restartfe = mv_network.setup_network(systemconfig)
+ if restartfe == True :
+ logging.debug(" Setting the frontend to restart due to network change")
+ cmdmodule["restartfe"] = True
@@ -109,7 +112,7 @@ def main(argv):
restart = mv_ir.setup_ir(systemconfig,data_config)
restartfe = restart[0]
restartlcd = restart[1]
- if restartfe == True:
+ if restartfe == True :
logging.debug(" Setting the frontend to restart due to lirc change")
cmdmodule["restartfe"] = True
cmdmodule["smolt"] = True