summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/LinHES-config/systemconfig.sh
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-02-12 18:35:11 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-02-12 18:35:11 (GMT)
commitee8437858ec0decf6ce36dfda90abde61f025016 (patch)
treec72a50b08c98959022abc83bb4e7f2990a058f3b /abs/core-testing/LinHES-config/systemconfig.sh
parentebbb20c55cb45ade45636694a9ef83f6138ab122 (diff)
parent8e38d056d05f4891acd61b8b242eeda433619f6c (diff)
downloadlinhes_pkgbuild-ee8437858ec0decf6ce36dfda90abde61f025016.zip
linhes_pkgbuild-ee8437858ec0decf6ce36dfda90abde61f025016.tar.gz
linhes_pkgbuild-ee8437858ec0decf6ce36dfda90abde61f025016.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Conflicts: abs/core-testing/fbsplash/PKGBUILD
Diffstat (limited to 'abs/core-testing/LinHES-config/systemconfig.sh')
-rwxr-xr-xabs/core-testing/LinHES-config/systemconfig.sh92
1 files changed, 59 insertions, 33 deletions
diff --git a/abs/core-testing/LinHES-config/systemconfig.sh b/abs/core-testing/LinHES-config/systemconfig.sh
index 8c21242..4fdbea0 100755
--- a/abs/core-testing/LinHES-config/systemconfig.sh
+++ b/abs/core-testing/LinHES-config/systemconfig.sh
@@ -391,45 +391,71 @@ function setupplugins (){
pkglistinstall=""
pkglistremove=""
#default enabled
-for i in mythcontrols mythgallery mythmovietime mythmusic mythsmolt mythvideo mythappletrailers mythstream mythvodka
+for i in mythcontrols mythgallery mythmovietime mythmusic mythsmolt mythvideo
do
-eval pkgvalue=\$${i}
-
-if [ x$pkgvalue = x ]
- then
- pkglistinstall="$pkglistinstall $i$postfix"
- else
- if [ x$pkgvalue = x1 ]
- then
- pkglistinstall="$pkglistinstall $i$postfix"
- else
- pkglistremove="$pkglistremove $i$postfix"
- fi
- fi
-
-
-
+ eval pkgvalue=\$${i}
+ if [ x$pkgvalue = x ]
+ then
+ pkglistinstall="$pkglistinstall $i$postfix"
+ else
+ if [ x$pkgvalue = x1 ]
+ then
+ pkglistinstall="$pkglistinstall $i$postfix"
+ else
+ pkglistremove="$pkglistremove $i$postfix"
+ fi
+ fi
done
+#default disabled
+for i in mythphone mytharchive mythbrowser mythnews mythgame mythflix mythweather mythappletrailers mythstream mythvodka
+do
+ eval pkgvalue=\$${i}
+ if [ x$pkgvalue = x ]
+ then
+ pkglistremove="$pkglistremove $i$postfix"
+ else
+ if [ x$pkgvalue = x1 ]
+ then
+ pkglistinstall="$pkglistinstall $i$postfix"
+ else
+ pkglistremove="$pkglistremove $i$postfix"
+ fi
+ fi
+done
+#everything else
+for i in miro xe romdb xine dvdcss
+do
+ case $i in
+ xine)
+ if [ x$pkgvalue = x1 ]
+ then
+ pkglistinstall="$pkglistinstall xine-ui"
+ else
+ pkglistremove="$pkglistremove xine-ui"
+ fi
+ ;;
+ dvdcss)
+ if [ x$pkgvalue = x1 ]
+ then
+ pkglistinstall="$pkglistinstall libdvdcss"
+ else
+ pkglistremove="$pkglistremove libdvdcss"
+ fi
+ ;;
+ *)
+ if [ x$pkgvalue = x1 ]
+ then
+ pkglistinstall="$pkglistinstall $i"
+ else
+ pkglistremove="$pkglistremove $i"
+ fi
+ ;;
+esac
+done
-#default disabled
- for i in mythphone mytharchive mythbrowser mythnews mythgame mythflix mythweather
- do
-eval pkgvalue=\$${i}
-if [ x$pkgvalue = x ]
- then
- pkglistremove="$pkglistremove $i$postfix"
- else
- if [ x$pkgvalue = x1 ]
- then
- pkglistinstall="$pkglistinstall $i$postfix"
- else
- pkglistremove="$pkglistremove $i$postfix"
- fi
- fi
- done
install="$pkglistinstall $install"
remove="$pkglistremove $remove"