summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/LinHES-config
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-08-02 21:33:25 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-08-02 21:33:25 (GMT)
commitd3cdc0010fb49666796001edcacbfc408e9b8ea6 (patch)
treeed4aa50356de04cecd5460c8d6b158891ab36767 /abs/core-testing/LinHES-config
parent7224eedb7ce6cc6c4a520cc887c2c5b1eac16191 (diff)
parent9a4b520578e61b098b4dce7a3ba2376c0c74b01e (diff)
downloadlinhes_pkgbuild-d3cdc0010fb49666796001edcacbfc408e9b8ea6.zip
linhes_pkgbuild-d3cdc0010fb49666796001edcacbfc408e9b8ea6.tar.gz
linhes_pkgbuild-d3cdc0010fb49666796001edcacbfc408e9b8ea6.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/LinHES-config')
-rwxr-xr-xabs/core-testing/LinHES-config/PKGBUILD51
-rwxr-xr-xabs/core-testing/LinHES-config/systemconfig.py12
2 files changed, 51 insertions, 12 deletions
diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index 75439cc..d734e69 100755
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,13 +1,51 @@
pkgname=LinHES-config
pkgver=2.0
-pkgrel=65
+pkgrel=68
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
pkgdesc="Install and configure your system"
-depends=(bc libstatgrab mysql-python expect curl dnsutils parted sg3_utils nmbscan system-templates rsync python-parted ddcxinfo python-pexpect python-netifaces LinHES-timezone python-iplib)
+depends=(bc libstatgrab mysql-python expect curl dnsutils parted
+ sg3_utils nmbscan system-templates rsync python-parted
+ ddcxinfo python-pexpect python-netifaces LinHES-timezone
+ python-iplib mythinstall)
arch=('i686')
-source=(mv_install.py mv_config.py mythinstall.bin myth_user_call file_time_offset.py install-ui.xml install_proxy.sh install_functions.sh systemconfig.sh install_db_chroot.sh restore_default_settings.sh xconfig.sh timezip.py soundconfig.sh LinHES-release issue MythVantage.sh create_master.sh build_diskless.sh networkconfig.sh autocard.py restore_km_db_chroot.sh README mv_advanced.py mv_common.py mv_ir.py mv_misc.py mv_network.py mv_screensaver.py mv_smolt.py mv_software.py mv_webuser.py mv_hostype.py systemconfig.py myth_user_call.py)
+source=(mv_install.py
+ mv_config.py
+ myth_user_call
+ file_time_offset.py
+ install-ui.xml
+ install_proxy.sh
+ install_functions.sh
+ systemconfig.sh
+ install_db_chroot.sh
+ restore_default_settings.sh
+ xconfig.sh
+ timezip.py
+ soundconfig.sh
+ LinHES-release
+ issue
+ MythVantage.sh
+ create_master.sh
+ build_diskless.sh
+ networkconfig.sh
+ autocard.py
+ restore_km_db_chroot.sh
+ README
+ mv_advanced.py
+ mv_common.py
+ mv_ir.py
+ mv_misc.py
+ mv_network.py
+ mv_screensaver.py
+ mv_smolt.py
+ mv_software.py
+ mv_webuser.py
+ mv_hostype.py
+ systemconfig.py
+ myth_user_call.py)
+
install=LinHES.install
+
build() {
mkdir -p $startdir/pkg/etc
mkdir -p $startdir/pkg/usr/share/mythtv/themes/default
@@ -60,12 +98,5 @@ build() {
# copy over the ui files
install -m 0755 install-ui.xml $startdir/pkg/usr/share/mythtv/themes/default/
-
- #copy in the binaries
- install -m 4755 mythinstall.bin $MVDIR/bin/MythVantage
- cd $MVDIR/bin
- ln -s MythVantage mythvantage
- ln -s MythVantage mythinstall
- cd -
}
diff --git a/abs/core-testing/LinHES-config/systemconfig.py b/abs/core-testing/LinHES-config/systemconfig.py
index 4418003..b2f8529 100755
--- a/abs/core-testing/LinHES-config/systemconfig.py
+++ b/abs/core-testing/LinHES-config/systemconfig.py
@@ -50,9 +50,9 @@ def main(argv):
global systemconfig
systemconfig["MVROOT"]=MVROOT
restartlcd = False
- cmdmodule={"misc":False , "sleep":False , "hostype":False , "hostypec":False , "advanced":False , "audio":False , "network":False , "advancedX":False , "webuser":False , "restartfe":False , "reloadfe":False , "ddns":False , "screensaver":False , "ir":False , "this_is_install":False , "user":False, "software":False, "plugins":False, "smolt":False, "all":False}
+ cmdmodule={"misc":False , "sleep":False , "hostype":False , "hostypec":False , "advanced":False , "audio":False , "network":False , "advancedX":False , "webuser":False , "restartfe":False , "reloadfe":False , "ddns":False , "screensaver":False , "ir":False , "this_is_install":False , "user":False, "software":False, "plugins":False, "smolt":False, "all":False, "dhcp_request":False }
try:
- opts, args = getopt.getopt(argv, 'c:hm:', ["help","modules" ] )
+ opts, args = getopt.getopt(argv, 'c:hm:d:', ["help","modules" ] )
except getopt.GetoptError, why:
print why
usage()
@@ -65,6 +65,9 @@ def main(argv):
elif opt in ("-m"):
for i in arg.split(","):
cmdmodule[i]=True
+ elif opt in ("-d"):
+ dhcp_dev = arg
+
if cmdmodule["this_is_install"] or cmdmodule["hostypec"]:
systemconfig["hostypec"] = True
@@ -185,6 +188,11 @@ def main(argv):
mv_common.runcmd(cmd)
logging.info("__End of ssh user\n")
+ if cmdmodule["dhcp_request"]:
+ cmd = '''dhcpcd -t4 -h' ' -Td %s > /tmp/mvnetwork.dhcpinfo ''' %dhcp_dev
+ mv_common.runcmd(cmd)
+
+
if __name__ == "__main__":
config_file = "mv_config"