summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/LinHES-config
diff options
context:
space:
mode:
authorGreg Frost <gregfrost1@bigpond.com>2009-08-15 05:32:41 (GMT)
committerGreg Frost <gregfrost1@bigpond.com>2009-08-15 05:32:41 (GMT)
commit620cb6800d15e6b2b0738b6cdd29080d2685f70b (patch)
tree44e096ea99d29a83c190bc2fff49569a1b00092a /abs/core-testing/LinHES-config
parentac3fcc84dfa0692cf2b11a04d7266da47c2ff89c (diff)
downloadlinhes_pkgbuild-620cb6800d15e6b2b0738b6cdd29080d2685f70b.zip
linhes_pkgbuild-620cb6800d15e6b2b0738b6cdd29080d2685f70b.tar.gz
linhes_pkgbuild-620cb6800d15e6b2b0738b6cdd29080d2685f70b.tar.bz2
LinHES-config mythinstall: various timezone fixups
Diffstat (limited to 'abs/core-testing/LinHES-config')
-rw-r--r--abs/core-testing/LinHES-config/PKGBUILD2
-rwxr-xr-xabs/core-testing/LinHES-config/mv_install.py6
2 files changed, 5 insertions, 3 deletions
diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index 43ed4f8..77b9563 100644
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-config
pkgver=2.0
-pkgrel=85
+pkgrel=86
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
pkgdesc="Install and configure your system"
depends=(bc libstatgrab mysql-python expect curl dnsutils parted
diff --git a/abs/core-testing/LinHES-config/mv_install.py b/abs/core-testing/LinHES-config/mv_install.py
index 1ebc2f1..2f2d1c2 100755
--- a/abs/core-testing/LinHES-config/mv_install.py
+++ b/abs/core-testing/LinHES-config/mv_install.py
@@ -144,13 +144,15 @@ def timezone_to_db(timefile):
f.close()
except:
logging.debug("Couldn't open /tmp/etc/timezone, will not set the timezone")
+ updatedb("HostTimeZone", "Unknown");
return
+ update_db("HostTimeZone", timezonecontents);
tzsplit = timezonecontents.partition('/')
print tzsplit
if tzsplit[2] == '' :
- update_db("HostTimeZoneRegion", tzsplit[0])
+ update_db("HostTimeZoneRegion", tzsplit[0])
else:
- update_db("HostTimeZoneRegion", tzsplit[0])
+ update_db("HostTimeZoneRegion", tzsplit[0])
tztemp="HostTimeZoneRegion_%s" % tzsplit[0]
update_db(tztemp, tzsplit[2])