summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/LinHES-config
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-01-13 05:27:16 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-01-13 05:27:16 (GMT)
commit72c6f7491c5986c68d12cfd66e276930c50b04fc (patch)
tree62e977e993bb8ca30d5a17ca996d8e88537c87c0 /abs/core-testing/LinHES-config
parent0c175bafc1fc5d3a3b884de3d8aed6f538a31552 (diff)
downloadlinhes_pkgbuild-72c6f7491c5986c68d12cfd66e276930c50b04fc.zip
linhes_pkgbuild-72c6f7491c5986c68d12cfd66e276930c50b04fc.tar.gz
linhes_pkgbuild-72c6f7491c5986c68d12cfd66e276930c50b04fc.tar.bz2
add --skip-resolve-hostnames to mysql startup scripts.
Diffstat (limited to 'abs/core-testing/LinHES-config')
-rwxr-xr-xabs/core-testing/LinHES-config/PKGBUILD2
-rwxr-xr-xabs/core-testing/LinHES-config/restore_default_settings.sh14
2 files changed, 9 insertions, 7 deletions
diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index 8114e24..6bc168e 100755
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-config
pkgver=1.0
-pkgrel=175
+pkgrel=177
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
pkgdesc="Install and configure your system"
depends=(bc libstatgrab mysql-python expect curl dnsutils parted sg3_utils nmbscan )
diff --git a/abs/core-testing/LinHES-config/restore_default_settings.sh b/abs/core-testing/LinHES-config/restore_default_settings.sh
index 5690f48..46c5fc9 100755
--- a/abs/core-testing/LinHES-config/restore_default_settings.sh
+++ b/abs/core-testing/LinHES-config/restore_default_settings.sh
@@ -13,6 +13,7 @@ Thistemplate=""
declare -i OVERRIDE=0
declare -i EVERYTHING=0
+
function CMD_DEFINE () {
#add override check
if [ x$Thistemplate = xsyssettings -a $OVERRIDE -eq 1 ]
@@ -28,21 +29,22 @@ function CMD_DEFINE () {
}
function SQL_DEFINE () {
+ thostname=`echo ${hostname}|tr - _`
#$1 is the table name
if [ $1 = "settings" ]
then
- ALTERSQL="Alter table temp_${1}_${hostname} add unique ( value )"
+ ALTERSQL="Alter table temp_${1}_${thostname} add unique ( value )"
else
ALTERSQL=";"
fi
- CREATESQL="create table temp_${1}_${hostname} like $1;"
- COPY_TMP_SQL="replace into temp_${1}_${hostname} (select * from $1 where hostname=\"$hostname\");"
- INSERTSQL="LOAD DATA local INFILE '/tmp/$1.txt' REPLACE INTO TABLE temp_${1}_${hostname} FIELDS TERMINATED BY '\t';"
+ CREATESQL="create table temp_${1}_${thostname} like $1;"
+ COPY_TMP_SQL="replace into temp_${1}_${thostname} (select * from $1 where hostname=\"$hostname\");"
+ INSERTSQL="LOAD DATA local INFILE '/tmp/$1.txt' REPLACE INTO TABLE temp_${1}_${thostname} FIELDS TERMINATED BY '\t';"
#INSERTSQL="LOAD DATA local INFILE '$TEMPLATES/$Thistemplate/$1.txt' REPLACE INTO TABLE temp_${1}_${hostname} FIELDS TERMINATED BY '\t';"
DROPSQL="delete from $1 where hostname=\"$hostname\";"
- COPY_BCK_SQL="replace into $1 (select * from temp_${1}_${hostname} where hostname=\"$hostname\");"
- DROP_TABLE="Drop table temp_${1}_${hostname}"
+ COPY_BCK_SQL="replace into $1 (select * from temp_${1}_${thostname} where hostname=\"$hostname\");"
+ DROP_TABLE="Drop table temp_${1}_${thostname}"
}
function ARG_ERR() {