summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/LinHES-config
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-06-26 03:55:59 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-06-26 03:55:59 (GMT)
commitac03a46cd8605f6e5b89f939bd79b35e00a63a75 (patch)
tree0aca6ddd6084c1a4d446acd3b7d5aa19f150284e /abs/core-testing/LinHES-config
parent3bb575e9755a3a225943cbd9843ac72449b788e1 (diff)
downloadlinhes_pkgbuild-ac03a46cd8605f6e5b89f939bd79b35e00a63a75.zip
linhes_pkgbuild-ac03a46cd8605f6e5b89f939bd79b35e00a63a75.tar.gz
linhes_pkgbuild-ac03a46cd8605f6e5b89f939bd79b35e00a63a75.tar.bz2
linhes-config:install_proxy, catch corner case for hostname check.
if the nameserver for this host can't be found assume it's ok.
Diffstat (limited to 'abs/core-testing/LinHES-config')
-rwxr-xr-xabs/core-testing/LinHES-config/PKGBUILD2
-rwxr-xr-xabs/core-testing/LinHES-config/install_proxy.sh6
2 files changed, 7 insertions, 1 deletions
diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index cc67e21..27e5526 100755
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-config
pkgver=2.0
-pkgrel=26
+pkgrel=27
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
pkgdesc="Install and configure your system"
depends=(bc libstatgrab mysql-python expect curl dnsutils parted sg3_utils nmbscan system-templates rsync python-parted ddcxinfo)
diff --git a/abs/core-testing/LinHES-config/install_proxy.sh b/abs/core-testing/LinHES-config/install_proxy.sh
index bedacbf..dd4be79 100755
--- a/abs/core-testing/LinHES-config/install_proxy.sh
+++ b/abs/core-testing/LinHES-config/install_proxy.sh
@@ -132,6 +132,12 @@ case $1 in
status=1
fi
+ if [ $hoip = "out;" ]
+ then
+ echo "DNS servers not found"
+ status=1
+ fi
+
unkownhost=`host unkown.linhes.org |head -n1 `
unkownhostip=`echo $unkownhost |awk '{print $4}'`