summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/alsa-utils/alsa
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-01-12 19:19:50 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-01-12 19:19:50 (GMT)
commit6c619a60fd89b5e75a93cff06977c552ddf1e621 (patch)
tree630ca50ea1c128c4be85ce920ecf034c561bf7fe /abs/core-testing/alsa-utils/alsa
parent0b2b9b97e95f8f8bfda1d1fe09136d121cd0750d (diff)
parent634dff8fdd0a9c866c92f0020f282c23d1a438d8 (diff)
downloadlinhes_pkgbuild-6c619a60fd89b5e75a93cff06977c552ddf1e621.zip
linhes_pkgbuild-6c619a60fd89b5e75a93cff06977c552ddf1e621.tar.gz
linhes_pkgbuild-6c619a60fd89b5e75a93cff06977c552ddf1e621.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD.git
Conflicts: abs/core-testing/LinHES-config/PKGBUILD
Diffstat (limited to 'abs/core-testing/alsa-utils/alsa')
-rwxr-xr-xabs/core-testing/alsa-utils/alsa28
1 files changed, 18 insertions, 10 deletions
diff --git a/abs/core-testing/alsa-utils/alsa b/abs/core-testing/alsa-utils/alsa
index 2581a9a..e1d6f28 100755
--- a/abs/core-testing/alsa-utils/alsa
+++ b/abs/core-testing/alsa-utils/alsa
@@ -7,7 +7,7 @@
case "$1" in
start)
stat_busy "Restoring ALSA Levels"
- /usr/sbin/alsactl restore
+ /usr/sbin/alsactl $ALSA_ARGS restore
if [ $? -gt 0 ]; then
stat_fail
else
@@ -17,20 +17,28 @@ case "$1" in
POWERSAVE=${POWERSAVE:-0}
if [ -e /sys/module/snd_ac97_codec/parameters/power_save \
- -a $POWERSAVE -ne 0 ]; then
- echo $POWERSAVE > /sys/module/snd_ac97_codec/parameters/power_save
- echo 1 > /dev/dsp
+ -a $POWERSAVE -ne 0 ]; then
+ echo $POWERSAVE > /sys/module/snd_ac97_codec/parameters/power_save
+ echo 1 > /dev/dsp
fi
if [ -e /sys/module/snd_hda_intel/parameters/power_save \
- -a $POWERSAVE -ne 0 ]; then
- echo $POWERSAVE > /sys/module/snd_hda_intel/parameters/power_save
- echo 1 > /dev/dsp
+ -a $POWERSAVE -ne 0 ]; then
+ echo $POWERSAVE > /sys/module/snd_hda_intel/parameters/power_save
+ echo 1 > /dev/dsp
fi
;;
stop)
- stat_busy "Saving ALSA Levels"
- /usr/sbin/alsactl store
+ SAVE_VOLUME=${SAVE_VOLUME:-yes}
+ if [ "$SAVE_VOLUME" == "yes" ]; then
+ stat_busy "Saving ALSA Levels"
+ /usr/sbin/alsactl $ALSA_ARGS store
+ else
+ stat_busy "Stopping ALSA"
+ fi
+ if [ "$MUTE_VOLUME" == "yes" ]; then
+ /usr/bin/amixer -q set Master 0 mute
+ fi
if [ $? -gt 0 ]; then
stat_fail
else
@@ -44,5 +52,5 @@ case "$1" in
$0 start
;;
*)
- echo "usage: $0 {start|stop|restart}"
+ echo "usage: $0 {start|stop|restart}"
esac