summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/atl1e/atl1e.install
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verison.net>2010-05-04 00:27:08 (GMT)
committerMichael Hanson <hansonorders@verison.net>2010-05-04 00:27:08 (GMT)
commitb94d28649509115ec6821da376f88d284fe34e1f (patch)
treecdf0401200e0c93693237158e4cbc1497187f680 /abs/core-testing/atl1e/atl1e.install
parent4629a7669ffba21068576ca8aac2c2051d360536 (diff)
parent53625148909b257564b35ba93ff3f4fd18f983df (diff)
downloadlinhes_pkgbuild-b94d28649509115ec6821da376f88d284fe34e1f.zip
linhes_pkgbuild-b94d28649509115ec6821da376f88d284fe34e1f.tar.gz
linhes_pkgbuild-b94d28649509115ec6821da376f88d284fe34e1f.tar.bz2
Merge branch 'master' of mihanson@knoppmyth.net:LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/atl1e/atl1e.install')
-rw-r--r--abs/core-testing/atl1e/atl1e.install23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/core-testing/atl1e/atl1e.install b/abs/core-testing/atl1e/atl1e.install
new file mode 100644
index 0000000..7ae7ed0
--- /dev/null
+++ b/abs/core-testing/atl1e/atl1e.install
@@ -0,0 +1,23 @@
+# arg 1: the new package version
+post_install() {
+ KERNEL_VERSION='2.6.28-LinHES'
+ depmod -ae -v $KERNEL_VERSION > /dev/null 2>&1
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ KERNEL_VERSION='2.6.28-LinHES'
+ depmod -ae -v $KERNEL_VERSION > /dev/null 2>&1
+
+}
+
+# arg 1: the old package version
+post_remove() {
+ KERNEL_VERSION='2.6.28-LinHES'
+ depmod -ae -v $KERNEL_VERSION > /dev/null 2>&1
+}
+
+op=$1
+shift
+$op $*