summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/aumix/PKGBUILD
diff options
context:
space:
mode:
authorBob Igo <bob@stormlogic.com>2009-06-03 17:01:26 (GMT)
committerBob Igo <bob@stormlogic.com>2009-06-03 17:01:26 (GMT)
commit668064b7cb79759786d5ab3045ce89c8b9bb9ffe (patch)
tree8a393974d1a72491b13613fa141ec636947f121e /abs/core-testing/aumix/PKGBUILD
parent03f66cf733f73ecc62b9a71f569b03453f895ea4 (diff)
parentd6b48b672d3c144cc45f9c90bb73bf843ee7eef5 (diff)
downloadlinhes_pkgbuild-668064b7cb79759786d5ab3045ce89c8b9bb9ffe.zip
linhes_pkgbuild-668064b7cb79759786d5ab3045ce89c8b9bb9ffe.tar.gz
linhes_pkgbuild-668064b7cb79759786d5ab3045ce89c8b9bb9ffe.tar.bz2
Merge branch 'master' of ssh://igo@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/aumix/PKGBUILD')
-rw-r--r--abs/core-testing/aumix/PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/abs/core-testing/aumix/PKGBUILD b/abs/core-testing/aumix/PKGBUILD
new file mode 100644
index 0000000..560427f
--- /dev/null
+++ b/abs/core-testing/aumix/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=aumix
+pkgver=2.8
+pkgrel=3
+pkgdesc="A color text mode sound mixer with GPM support"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://www.jpj.net/~trevor/aumix.html"
+depends=('gpm')
+conflicts=('aumix-gtk')
+provides=('aumix-gtk')
+source=(http://jpj.net/~trevor/aumix/aumix-$pkgver.tar.bz2 aumix.patch)
+md5sums=('dc3fc7209752207c23e7c94ab886b340' 'a4dae53812a41b7576228c37856c701b')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ patch -Np1 <../aumix.patch || return 1
+ # we build without X/GTK support so we can avoid the dependencies.
+ # if you want GTK support, you can rebuild aumix from your ABS tree.
+ ./configure --prefix=/usr --without-alsa --without-gtk --without-gtk1 || return 1
+ make || return 1
+ make DESTDIR=$startdir/pkg install || return 1
+}