summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/aumix/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-06-04 13:44:45 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-06-04 13:44:45 (GMT)
commit7b7126f096fdc8e6da3ca450b25e8488641898d7 (patch)
treede022809876471be2af3256782ca86aee19600fc /abs/core-testing/aumix/PKGBUILD
parentbb8e9844185c984a76049dddc087bdf347ff3c9f (diff)
parent178de28c12a605337c92cb8b02b07a4db35f3603 (diff)
downloadlinhes_pkgbuild-7b7126f096fdc8e6da3ca450b25e8488641898d7.zip
linhes_pkgbuild-7b7126f096fdc8e6da3ca450b25e8488641898d7.tar.gz
linhes_pkgbuild-7b7126f096fdc8e6da3ca450b25e8488641898d7.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD into linhes-config-python
* 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD: Initial inclusion. Added aumix. Bumped ver to latest SVN.
Diffstat (limited to 'abs/core-testing/aumix/PKGBUILD')
-rw-r--r--abs/core-testing/aumix/PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/abs/core-testing/aumix/PKGBUILD b/abs/core-testing/aumix/PKGBUILD
new file mode 100644
index 0000000..560427f
--- /dev/null
+++ b/abs/core-testing/aumix/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=aumix
+pkgver=2.8
+pkgrel=3
+pkgdesc="A color text mode sound mixer with GPM support"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://www.jpj.net/~trevor/aumix.html"
+depends=('gpm')
+conflicts=('aumix-gtk')
+provides=('aumix-gtk')
+source=(http://jpj.net/~trevor/aumix/aumix-$pkgver.tar.bz2 aumix.patch)
+md5sums=('dc3fc7209752207c23e7c94ab886b340' 'a4dae53812a41b7576228c37856c701b')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ patch -Np1 <../aumix.patch || return 1
+ # we build without X/GTK support so we can avoid the dependencies.
+ # if you want GTK support, you can rebuild aumix from your ABS tree.
+ ./configure --prefix=/usr --without-alsa --without-gtk --without-gtk1 || return 1
+ make || return 1
+ make DESTDIR=$startdir/pkg install || return 1
+}