summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/ddcxinfo
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-08-01 03:14:54 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-08-01 03:14:54 (GMT)
commit7b35632e80f168d8c5f2220bf610ee7e24b81270 (patch)
tree8facf3fa565911f056a08e38f6a5eed0f756f9c6 /abs/core-testing/ddcxinfo
parent7e10f51870aa10be3b35d7912a7b54e30f608bb8 (diff)
parent7accc0f042acdfdca9f067b1d4011d6ac01b1a74 (diff)
downloadlinhes_pkgbuild-7b35632e80f168d8c5f2220bf610ee7e24b81270.zip
linhes_pkgbuild-7b35632e80f168d8c5f2220bf610ee7e24b81270.tar.gz
linhes_pkgbuild-7b35632e80f168d8c5f2220bf610ee7e24b81270.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Conflicts: abs/core-testing/LinHES-config/PKGBUILD
Diffstat (limited to 'abs/core-testing/ddcxinfo')
-rw-r--r--abs/core-testing/ddcxinfo/PKGBUILD6
-rw-r--r--abs/core-testing/ddcxinfo/lrmi.patch18
2 files changed, 22 insertions, 2 deletions
diff --git a/abs/core-testing/ddcxinfo/PKGBUILD b/abs/core-testing/ddcxinfo/PKGBUILD
index 94707ef..b358c0c 100644
--- a/abs/core-testing/ddcxinfo/PKGBUILD
+++ b/abs/core-testing/ddcxinfo/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=ddcxinfo
pkgver=0.6.19
-pkgrel=2
+pkgrel=3
pkgdesc="DDC readout using the VESA BIOS extension"
url="http://www.t2-project.org/packages/ddcxinfo.html"
license="GPL"
@@ -11,12 +11,14 @@ replaces=()
backup=()
arch=('i686')
install=
-source=(http://www.kanotix.com/files/debian/pool/main/d/ddcxinfo-kanotix/$pkgname-kanotix_$pkgver.tar.gz)
+source=(http://www.kanotix.com/files/debian/pool/main/d/ddcxinfo-kanotix/$pkgname-kanotix_$pkgver.tar.gz
+ lrmi.patch)
build() {
cd $startdir/src/$pkgname-kanotix-$pkgver
mkdir -p $startdir/pkg/usr/sbin
+ patch -p1 < $startdir/src/lrmi.patch
make DESTDIR=$startdir/pkg install
cp svgamodes $startdir/pkg/usr/sbin/
chmod +s $startdir/pkg/usr/sbin/ddcprobe
diff --git a/abs/core-testing/ddcxinfo/lrmi.patch b/abs/core-testing/ddcxinfo/lrmi.patch
new file mode 100644
index 0000000..ca735fa
--- /dev/null
+++ b/abs/core-testing/ddcxinfo/lrmi.patch
@@ -0,0 +1,18 @@
+Common subdirectories: ddcxinfo-kanotix-0.6.19-orig/debian and ddcxinfo-kanotix-0.6.19/debian
+diff -u ddcxinfo-kanotix-0.6.19-orig/lrmi.c ddcxinfo-kanotix-0.6.19/lrmi.c
+--- ddcxinfo-kanotix-0.6.19-orig/lrmi.c 2009-07-25 06:15:09.000000000 +0000
++++ ddcxinfo-kanotix-0.6.19/lrmi.c 2009-07-25 06:17:22.000000000 +0000
+@@ -170,6 +170,13 @@
+ }
+ }
+
++#ifndef TF_MASK
++#define TF_MASK X86_EFLAGS_TF
++#define IF_MASK X86_EFLAGS_IF
++#define IOPL_MASK X86_EFLAGS_IOPL
++#define VIF_MASK X86_EFLAGS_VIF
++#define VIP_MASK X86_EFLAGS_VIP
++#endif
+
+ #define DEFAULT_VM86_FLAGS (IF_MASK | IOPL_MASK)
+ #define DEFAULT_STACK_SIZE 0x1000