summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/dhcp/dhcp.install
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-06-21 01:37:59 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-06-21 01:37:59 (GMT)
commit1baf8111524169f6d9349223e7764a43e2525a1a (patch)
tree334d56a08cdf036f9aebded302406652614e8087 /abs/core-testing/dhcp/dhcp.install
parent841af294b3de32594fc380a54df1938117f976e8 (diff)
parent87ee63ae6cc83c1d660a3fafe10d94ae06318e8e (diff)
downloadlinhes_pkgbuild-1baf8111524169f6d9349223e7764a43e2525a1a.zip
linhes_pkgbuild-1baf8111524169f6d9349223e7764a43e2525a1a.tar.gz
linhes_pkgbuild-1baf8111524169f6d9349223e7764a43e2525a1a.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/dhcp/dhcp.install')
-rw-r--r--abs/core-testing/dhcp/dhcp.install15
1 files changed, 15 insertions, 0 deletions
diff --git a/abs/core-testing/dhcp/dhcp.install b/abs/core-testing/dhcp/dhcp.install
new file mode 100644
index 0000000..edb84b1
--- /dev/null
+++ b/abs/core-testing/dhcp/dhcp.install
@@ -0,0 +1,15 @@
+# arg 1: the new package version
+post_install() {
+ [ -f var/state/dhcp/dhcpd.leases ] || : >var/state/dhcp/dhcpd.leases
+ echo "If dhcpd doesn' start ensure the ipv6 kernel module is loaded."
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ post_install $1
+}
+
+op=$1
+shift
+$op $*