summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/dhcp/dhcpd
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-06-21 01:37:59 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-06-21 01:37:59 (GMT)
commit1baf8111524169f6d9349223e7764a43e2525a1a (patch)
tree334d56a08cdf036f9aebded302406652614e8087 /abs/core-testing/dhcp/dhcpd
parent841af294b3de32594fc380a54df1938117f976e8 (diff)
parent87ee63ae6cc83c1d660a3fafe10d94ae06318e8e (diff)
downloadlinhes_pkgbuild-1baf8111524169f6d9349223e7764a43e2525a1a.zip
linhes_pkgbuild-1baf8111524169f6d9349223e7764a43e2525a1a.tar.gz
linhes_pkgbuild-1baf8111524169f6d9349223e7764a43e2525a1a.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/dhcp/dhcpd')
-rwxr-xr-xabs/core-testing/dhcp/dhcpd39
1 files changed, 39 insertions, 0 deletions
diff --git a/abs/core-testing/dhcp/dhcpd b/abs/core-testing/dhcp/dhcpd
new file mode 100755
index 0000000..0aebcc8
--- /dev/null
+++ b/abs/core-testing/dhcp/dhcpd
@@ -0,0 +1,39 @@
+#!/bin/bash
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+PIDFILE="/var/run/dhcpd.pid"
+PID=`cat $PIDFILE 2>/dev/null`
+case "$1" in
+ start)
+ stat_busy "Starting DHCP Server"
+ if [ "$PID" = "" ]; then
+ /usr/sbin/dhcpd -q
+ fi
+ if [ "$PID" != "" -o $? -gt 0 ]; then
+ stat_fail
+ else
+ add_daemon dhcpd
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping DHCP Server"
+ [ ! -z "$PID" ] && kill $PID &> /dev/null
+ rm -f $PIDFILE
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ rm_daemon dhcpd
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ sleep 1
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart}"
+esac