summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/fbsplash/fbsplash.daemon
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-09-08 07:33:44 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-09-08 07:33:44 (GMT)
commit525753e4a1a139e088d8ac120b19fbab6c0aaaa6 (patch)
tree35cef28abb613da4f58e83f6abbe4bd4cfa244bf /abs/core-testing/fbsplash/fbsplash.daemon
parent592e3cad43ef12c53f523145d0fd981b54f2a049 (diff)
parentb172f79fadb565ecfbcec9508f9377d8618a4f4c (diff)
downloadlinhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.zip
linhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.tar.gz
linhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/fbsplash/fbsplash.daemon')
-rw-r--r--abs/core-testing/fbsplash/fbsplash.daemon56
1 files changed, 0 insertions, 56 deletions
diff --git a/abs/core-testing/fbsplash/fbsplash.daemon b/abs/core-testing/fbsplash/fbsplash.daemon
deleted file mode 100644
index e615500..0000000
--- a/abs/core-testing/fbsplash/fbsplash.daemon
+++ /dev/null
@@ -1,56 +0,0 @@
-#!/bin/bash
-
-source /etc/rc.conf
-source /etc/rc.d/functions
-
-source /sbin/splash-functions.sh
-source /etc/conf.d/fbsplash.conf
-
-case "$1" in
- start)
- if [ "$(fbcondecor_supported)" = "true" ]
- then
- THEME="linhes"
- if [ -f /proc/cmdline ]; then
- OPTIONS=$(grep -o 'splash=[^ ]*' /proc/cmdline)
- for i in $(echo "${OPTIONS#*=}" | sed -e 's/,/ /g')
- do
- case ${i%:*} in
- theme) THEME=${i#*:} ;;
- esac
- done
- fi
- stat_busy "Setting fbcondecor console images"
- for TTY in ${SPLASH_TTYS}; do
- fbcondecor_set_theme ${TTY} ${THEME}
- done
- stat_done
- fi
- save_boot_steps
- splash_exit
- ;;
-
- kill)
- if [ "$(fbcondecor_supported)" = "true" ]
- then
- stat_busy "Disabling fbcondecor console images"
- for TTY in ${SPLASH_TTYS}; do
- fbcondecor_remove_theme ${TTY}
- done
- stat_done
- fi
- ;;
-
- restart)
- $0 kill
- sleep 1
- $1 start
- ;;
-
- *)
- echo "usage: $0 {start|restart|kill}"
-esac
-exit 0
-
-#EOF
-