summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/gtk2/gtk2.install
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-12-01 05:08:11 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-12-01 05:08:11 (GMT)
commit60a85896eec2c8e0e8b1c78c83cc39222649ceae (patch)
tree6adc8c3984c870b1faa45ea02781c9b4505c7083 /abs/core-testing/gtk2/gtk2.install
parente8efa7348d5849656b3f3c51c6ae9c2b4089053e (diff)
parentd615d8fb4dd78b2e51708b321ad77b6304458bfd (diff)
downloadlinhes_pkgbuild-60a85896eec2c8e0e8b1c78c83cc39222649ceae.zip
linhes_pkgbuild-60a85896eec2c8e0e8b1c78c83cc39222649ceae.tar.gz
linhes_pkgbuild-60a85896eec2c8e0e8b1c78c83cc39222649ceae.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD.git
Diffstat (limited to 'abs/core-testing/gtk2/gtk2.install')
-rw-r--r--abs/core-testing/gtk2/gtk2.install24
1 files changed, 5 insertions, 19 deletions
diff --git a/abs/core-testing/gtk2/gtk2.install b/abs/core-testing/gtk2/gtk2.install
index 3b4a881..6d415ad 100644
--- a/abs/core-testing/gtk2/gtk2.install
+++ b/abs/core-testing/gtk2/gtk2.install
@@ -1,27 +1,13 @@
-# arg 1: the new package version
post_install() {
- # we need to ldconfig first, in case xfree86's libs aren't
- # in ld.so.cache yet
- sbin/ldconfig -r .
- mkdir -p etc/gtk-2.0 &>/dev/null
- usr/bin/gtk-query-immodules-2.0 >etc/gtk-2.0/gtk.immodules
- usr/bin/gdk-pixbuf-query-loaders >etc/gtk-2.0/gdk-pixbuf.loaders
+ usr/bin/gtk-query-immodules-2.0 > etc/gtk-2.0/gtk.immodules
+ usr/bin/gdk-pixbuf-query-loaders > etc/gtk-2.0/gdk-pixbuf.loaders
}
-# arg 1: the new package version
-# arg 2: the old package version
post_upgrade() {
- post_install $1
+ post_install
}
-# arg 1: the old package version
pre_remove() {
- rm -f etc/gtk-2.0/gtk.immodules &>/dev/null
- rm -f etc/gtk-2.0/gdk-pixbuf.loaders &>/dev/null
- rmdir etc/gtk-2.0 &>/dev/null
+ rm -f etc/gtk-2.0/gtk.immodules &>/dev/null
+ rm -f etc/gtk-2.0/gdk-pixbuf.loaders &>/dev/null
}
-
-op=$1
-shift
-
-$op $*