summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/gtk2/gtk2.install
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2008-12-01 04:57:32 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2008-12-01 04:57:32 (GMT)
commite4e922e8206bce66217e08b678b10465036dd44c (patch)
tree2287e4155c9d3cb7fb308842313af33535621de7 /abs/core-testing/gtk2/gtk2.install
parentdad9cc7a179efa966154cc5b945f2f6c4da7f477 (diff)
downloadlinhes_pkgbuild-e4e922e8206bce66217e08b678b10465036dd44c.zip
linhes_pkgbuild-e4e922e8206bce66217e08b678b10465036dd44c.tar.gz
linhes_pkgbuild-e4e922e8206bce66217e08b678b10465036dd44c.tar.bz2
PKGBUILDs for emulators and deps. Removed knoppmyth.xml and motion.xml. Modified mailmenu patch to refer to linhes.xml.
Diffstat (limited to 'abs/core-testing/gtk2/gtk2.install')
-rw-r--r--abs/core-testing/gtk2/gtk2.install24
1 files changed, 5 insertions, 19 deletions
diff --git a/abs/core-testing/gtk2/gtk2.install b/abs/core-testing/gtk2/gtk2.install
index 3b4a881..6d415ad 100644
--- a/abs/core-testing/gtk2/gtk2.install
+++ b/abs/core-testing/gtk2/gtk2.install
@@ -1,27 +1,13 @@
-# arg 1: the new package version
post_install() {
- # we need to ldconfig first, in case xfree86's libs aren't
- # in ld.so.cache yet
- sbin/ldconfig -r .
- mkdir -p etc/gtk-2.0 &>/dev/null
- usr/bin/gtk-query-immodules-2.0 >etc/gtk-2.0/gtk.immodules
- usr/bin/gdk-pixbuf-query-loaders >etc/gtk-2.0/gdk-pixbuf.loaders
+ usr/bin/gtk-query-immodules-2.0 > etc/gtk-2.0/gtk.immodules
+ usr/bin/gdk-pixbuf-query-loaders > etc/gtk-2.0/gdk-pixbuf.loaders
}
-# arg 1: the new package version
-# arg 2: the old package version
post_upgrade() {
- post_install $1
+ post_install
}
-# arg 1: the old package version
pre_remove() {
- rm -f etc/gtk-2.0/gtk.immodules &>/dev/null
- rm -f etc/gtk-2.0/gdk-pixbuf.loaders &>/dev/null
- rmdir etc/gtk-2.0 &>/dev/null
+ rm -f etc/gtk-2.0/gtk.immodules &>/dev/null
+ rm -f etc/gtk-2.0/gdk-pixbuf.loaders &>/dev/null
}
-
-op=$1
-shift
-
-$op $*