summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/hal/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-01-12 19:19:50 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-01-12 19:19:50 (GMT)
commit6c619a60fd89b5e75a93cff06977c552ddf1e621 (patch)
tree630ca50ea1c128c4be85ce920ecf034c561bf7fe /abs/core-testing/hal/PKGBUILD
parent0b2b9b97e95f8f8bfda1d1fe09136d121cd0750d (diff)
parent634dff8fdd0a9c866c92f0020f282c23d1a438d8 (diff)
downloadlinhes_pkgbuild-6c619a60fd89b5e75a93cff06977c552ddf1e621.zip
linhes_pkgbuild-6c619a60fd89b5e75a93cff06977c552ddf1e621.tar.gz
linhes_pkgbuild-6c619a60fd89b5e75a93cff06977c552ddf1e621.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD.git
Conflicts: abs/core-testing/LinHES-config/PKGBUILD
Diffstat (limited to 'abs/core-testing/hal/PKGBUILD')
-rw-r--r--abs/core-testing/hal/PKGBUILD22
1 files changed, 16 insertions, 6 deletions
diff --git a/abs/core-testing/hal/PKGBUILD b/abs/core-testing/hal/PKGBUILD
index f1a3b3f..4bad72d 100644
--- a/abs/core-testing/hal/PKGBUILD
+++ b/abs/core-testing/hal/PKGBUILD
@@ -1,10 +1,10 @@
-# $Id: PKGBUILD 8861 2008-08-16 22:34:13Z eric $
+# $Id: PKGBUILD 12450 2008-09-14 10:49:05Z pierre $
# Maintainer: Jan de Groot <jgc@archlinux.org>
# Contributor: Link Dupont <link@subpop.net>
pkgname=hal
pkgver=0.5.11
-pkgrel=1
+pkgrel=4
pkgdesc="Hardware Abstraction Layer"
arch=(i686 x86_64)
license=('GPL' 'custom')
@@ -18,10 +18,17 @@ source=(http://hal.freedesktop.org/releases/${pkgname}-${pkgver}.tar.bz2
hal-policy.patch
cryptsetup_location.patch
hal-0.5.9-hide-diagnostic.patch
- ntfs3g-valid-options.patch)
-md5sums=('5e8935ab61bcb14afd2d4548084aace0' '277e96ac130d7bfce0b30f0b80db8782'\
- '18dcdaa79952e2057c2e4745fbc8ad52' 'c688a3c6574699365926f4fef7441545'\
- '4d4b6801a1cedca22b8bdd9db73b16fb' '4242a2c78885e396f639d0cd5e33218c')
+ ntfs3g-valid-options.patch
+ fix-udev-compatibility.patch
+ ntfs-mount-fix.patch)
+md5sums=('5e8935ab61bcb14afd2d4548084aace0'
+ '277e96ac130d7bfce0b30f0b80db8782'
+ '18dcdaa79952e2057c2e4745fbc8ad52'
+ 'c688a3c6574699365926f4fef7441545'
+ '4d4b6801a1cedca22b8bdd9db73b16fb'
+ '4242a2c78885e396f639d0cd5e33218c'
+ '1a33d73fa422df2f05b7e3483836f778'
+ '96cf8835c30dc581c4fcf72b6ad7675e')
build() {
cd ${startdir}/src/${pkgname}-${pkgver}
@@ -29,6 +36,9 @@ build() {
patch -Np1 -i ${startdir}/src/cryptsetup_location.patch || return 1
patch -Np1 -i ${startdir}/src/hal-0.5.9-hide-diagnostic.patch || return 1
patch -Np0 -i ${startdir}/src/ntfs3g-valid-options.patch || return 1
+ # Fix compatibility with udev 126 and later
+ patch -Np1 -i ${startdir}/src/fix-udev-compatibility.patch || return 1
+ patch -p0 -i ${srcdir}/ntfs-mount-fix.patch || return 1
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
--libexecdir=/usr/lib/hal --enable-static=no \