summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/hwd
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-11-29 21:41:50 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-11-29 21:41:50 (GMT)
commit1110292b3a2245a2ae0dafa870ca49440aaef8ac (patch)
tree447271e05bbbd9d968be8e50628f9973fcedd49e /abs/core-testing/hwd
parentf6313d0af90dee3a03b49a77cc61926a0ff801cc (diff)
downloadlinhes_pkgbuild-1110292b3a2245a2ae0dafa870ca49440aaef8ac.zip
linhes_pkgbuild-1110292b3a2245a2ae0dafa870ca49440aaef8ac.tar.gz
linhes_pkgbuild-1110292b3a2245a2ae0dafa870ca49440aaef8ac.tar.bz2
missing hwd pkg
Diffstat (limited to 'abs/core-testing/hwd')
-rw-r--r--abs/core-testing/hwd/PKGBUILD22
-rw-r--r--abs/core-testing/hwd/hwd.install15
2 files changed, 37 insertions, 0 deletions
diff --git a/abs/core-testing/hwd/PKGBUILD b/abs/core-testing/hwd/PKGBUILD
new file mode 100644
index 0000000..6073e2b
--- /dev/null
+++ b/abs/core-testing/hwd/PKGBUILD
@@ -0,0 +1,22 @@
+# $Id: PKGBUILD 3106 2008-06-19 18:56:52Z damir $
+# Maintainer: damir <damir@archlinux.org>
+# Contributor: Markku (rasat at Arch Linux Forums)
+
+pkgname=hwd
+pkgver=5.3.4
+pkgrel=1
+pkgdesc="Hardware detect for Arch Linux (devfs and udev)."
+url="http://user-contributions.org/projects/hwd/hwd.html"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('bash' 'pciutils' 'usbutils' 'ddcxinfo-arch' 'wget')
+install=hwd.install
+source=(http://user-contributions.org/projects/hwd/src/$pkgname-$pkgver.bin.tar.gz)
+
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ cp -R $startdir/src/$pkgname-$pkgver/{etc,usr} $startdir/pkg/ || return 1
+}
+
+md5sums=('002cfb6de516442203073084b6c1a7f9')
diff --git a/abs/core-testing/hwd/hwd.install b/abs/core-testing/hwd/hwd.install
new file mode 100644
index 0000000..e4c28cb
--- /dev/null
+++ b/abs/core-testing/hwd/hwd.install
@@ -0,0 +1,15 @@
+# arg 1: the new package version
+post_install() {
+ echo "==> Run 'hwd -u' to update xorgtable, pci-, and usb.ids."
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ echo "==> Run 'hwd -u' to update xorgtable, pci-, and usb.ids."
+}
+
+# arg 1: the old package version
+pre_remove() {
+ rm -R /etc/hwd >/dev/null 2>&1
+}