summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/iproute2/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-01-29 08:13:05 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-01-29 08:13:05 (GMT)
commita013e645fef4ebcd2bc91d81f54df8719e304c76 (patch)
tree2e7336e84d94847d75a269353bec02934d5ad240 /abs/core-testing/iproute2/PKGBUILD
parent6ffb99f0f222b64b022dcc14a61764e011d3e286 (diff)
downloadlinhes_pkgbuild-a013e645fef4ebcd2bc91d81f54df8719e304c76.zip
linhes_pkgbuild-a013e645fef4ebcd2bc91d81f54df8719e304c76.tar.gz
linhes_pkgbuild-a013e645fef4ebcd2bc91d81f54df8719e304c76.tar.bz2
Sync w/ upstream.
Diffstat (limited to 'abs/core-testing/iproute2/PKGBUILD')
-rw-r--r--abs/core-testing/iproute2/PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/abs/core-testing/iproute2/PKGBUILD b/abs/core-testing/iproute2/PKGBUILD
new file mode 100644
index 0000000..ed280e5
--- /dev/null
+++ b/abs/core-testing/iproute2/PKGBUILD
@@ -0,0 +1,37 @@
+# $Id: PKGBUILD 24415 2009-01-16 12:43:06Z ronald $
+# Maintainer: Ronald van Haren <ronald.archlinux.org>
+# Contributor: Judd Vinet <jvinet@zeroflux.org>
+
+pkgname=iproute2
+pkgver=2.6.28
+pkgrel=1
+pkgdesc="IP Routing Utilities"
+arch=('i686' 'x86_64')
+license=('GPL2')
+url="http://www.linux-foundation.org/en/Net:Iproute2"
+depends=('linux-atm' 'perl')
+
+provides=('iproute')
+conflicts=('iproute')
+replaces=('iproute')
+
+backup=('etc/iproute2/ematch_map' 'etc/iproute2/rt_dsfield' 'etc/iproute2/rt_protos' \
+ 'etc/iproute2/rt_realms' 'etc/iproute2/rt_scopes' 'etc/iproute2/rt_tables')
+
+source=(http://devresources.linux-foundation.org/dev/iproute2/download/iproute2-${pkgver}.tar.bz2)
+md5sums=('595f9b17320f69e8d30d2fa80f1bca14')
+
+build() {
+ cd $srcdir/iproute2-${pkgver}
+
+ sed -i 's|/usr/local/lib/iptables|/usr/lib/iptables|' include/iptables.h || return 1
+ sed -i 's|=/share|=/usr/share|' Makefile || return 1
+ sed -i 's|=/sbin|=/usr/sbin|' Makefile || return 1
+
+ ./configure || return 1
+ make || return 1
+ make DESTDIR=$pkgdir install || return 1
+
+# chmod 755 $pkgdir/usr/sbin/ifcfg || return 1
+
+}