summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/klibc/klibc-x86_64-fix-io.h.patch
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-09-08 07:33:44 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-09-08 07:33:44 (GMT)
commit525753e4a1a139e088d8ac120b19fbab6c0aaaa6 (patch)
tree35cef28abb613da4f58e83f6abbe4bd4cfa244bf /abs/core-testing/klibc/klibc-x86_64-fix-io.h.patch
parent592e3cad43ef12c53f523145d0fd981b54f2a049 (diff)
parentb172f79fadb565ecfbcec9508f9377d8618a4f4c (diff)
downloadlinhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.zip
linhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.tar.gz
linhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/klibc/klibc-x86_64-fix-io.h.patch')
-rw-r--r--abs/core-testing/klibc/klibc-x86_64-fix-io.h.patch28
1 files changed, 0 insertions, 28 deletions
diff --git a/abs/core-testing/klibc/klibc-x86_64-fix-io.h.patch b/abs/core-testing/klibc/klibc-x86_64-fix-io.h.patch
deleted file mode 100644
index 25ef789..0000000
--- a/abs/core-testing/klibc/klibc-x86_64-fix-io.h.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff -Nur klibc-1.5.14.orig/usr/include/arch/x86_64/sys/io.h klibc-1.5.14/usr/include/arch/x86_64/sys/io.h
---- klibc-1.5.14.orig/usr/include/arch/x86_64/sys/io.h 2008-07-30 23:06:03.000000000 +0200
-+++ klibc-1.5.14/usr/include/arch/x86_64/sys/io.h 2008-09-18 14:34:20.000000000 +0200
-@@ -60,21 +60,21 @@
- {
- unsigned char __v;
- asm volatile ("inb %1,%0" : "=a" (__v) : "dN"(__p));
-- return v;
-+ return __v;
- }
-
- static __inline__ unsigned short inw(unsigned short __p)
- {
- unsigned short __v;
- asm volatile ("inw %1,%0" : "=a" (__v) : "dN"(__p));
-- return v;
-+ return __v;
- }
-
- static __inline__ unsigned int inl(unsigned short __p)
- {
- unsigned int __v;
- asm volatile ("inl %1,%0" : "=a" (__v) : "dN"(__p));
-- return v;
-+ return __v;
- }
-
- /* String I/O macros */