summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/libjpeg/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-06-01 02:10:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-06-01 02:10:09 (GMT)
commitd7a06c882ef45d014319f98daf8e0dbe5599321d (patch)
tree08283d317915d613a4ea86513e8b8f626ceb243e /abs/core-testing/libjpeg/PKGBUILD
parent6aec480f40e73de0b179d0a91aa484266190f52b (diff)
parente9dc867012dd4553eeca9a67837688e762fcded6 (diff)
downloadlinhes_pkgbuild-d7a06c882ef45d014319f98daf8e0dbe5599321d.zip
linhes_pkgbuild-d7a06c882ef45d014319f98daf8e0dbe5599321d.tar.gz
linhes_pkgbuild-d7a06c882ef45d014319f98daf8e0dbe5599321d.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD into linhes-config-python
* 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD: lirc: pkg bump to just make it different then the submitted version in the ticket. lirc: change modmce patch to version 1.5 glass-wide: adding theme irqbalance: adding pkg fakeroot: add package linhes-scripts: adding idle.sh Bumped xbmc-svn to 20449 plus added common remote support fresh build bumped mythtv-svn to 20586 First cut at XBMC (svn with vdpau) updated libjpeg and added libsamplerate for XBMC build mythtv-svn bumped for new qt4 qt updated to 4.5.1 which: pkg bump used for testing, no functional changes. Bumped version to recompile. Bumped version for birthday present to community. Conflicts: abs/core-testing/LinHES-config/PKGBUILD
Diffstat (limited to 'abs/core-testing/libjpeg/PKGBUILD')
-rw-r--r--abs/core-testing/libjpeg/PKGBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/abs/core-testing/libjpeg/PKGBUILD b/abs/core-testing/libjpeg/PKGBUILD
index 807f7f5..baedcd4 100644
--- a/abs/core-testing/libjpeg/PKGBUILD
+++ b/abs/core-testing/libjpeg/PKGBUILD
@@ -1,21 +1,28 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: dorphell <dorphell@archlinux.org>
+# $Id$
+# Maintainer: Allan McRae <allan@archlinux.org>
# Committer: Judd Vinet <jvinet@zeroflux.org>
+
pkgname=libjpeg
pkgver=6b
-pkgrel=4
+pkgrel=6
pkgdesc="Library of JPEG support functions"
arch=('i686' 'x86_64')
+url="http://www.ijg.org/"
+license=('custom')
depends=('glibc')
+makedepends=('libtool')
+options=(!libtool)
source=(ftp://ftp.uu.net/graphics/jpeg/jpegsrc.v$pkgver.tar.gz)
md5sums=('dbd5f3b47ed13132f04c685d608a7547')
build() {
- cd $startdir/src/jpeg-$pkgver
+ cd $srcdir/jpeg-$pkgver
+ cp /usr/share/libtool/config/config.{guess,sub} .
+ sed -i "s#./libtool#libtool#" configure
./configure --prefix=/usr --enable-shared --enable-static
make || return 1
- mkdir -p $startdir/pkg/usr/{bin,lib,include,man/man1}
- make prefix=$startdir/pkg/usr install
-
- find $startdir/pkg -name '*.la' -exec rm {} \;
+ mkdir -p $pkgdir/usr/{bin,lib,include,share/man/man1}
+ make prefix=$pkgdir/usr mandir=$pkgdir/usr/share/man/man1 install
+ install -m644 jpegint.h $pkgdir/usr/include
+ install -Dm644 README $pkgdir/usr/share/licenses/libjpeg/README
}