summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/libjpeg6/libjpeg6.install
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-10-05 00:50:28 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-10-05 00:50:28 (GMT)
commit5c60706e8d334ce68c6483f3d1bc21200dd0ca44 (patch)
treece9401f49b2ed1222854e9df275bda5aaea21cb3 /abs/core-testing/libjpeg6/libjpeg6.install
parent0f7e1ec264befef1c9f9e160d4b451da4ae2e296 (diff)
parent567f8991a2ed30960bfdea9eed6bee9f8ba2de57 (diff)
downloadlinhes_pkgbuild-5c60706e8d334ce68c6483f3d1bc21200dd0ca44.zip
linhes_pkgbuild-5c60706e8d334ce68c6483f3d1bc21200dd0ca44.tar.gz
linhes_pkgbuild-5c60706e8d334ce68c6483f3d1bc21200dd0ca44.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/libjpeg6/libjpeg6.install')
-rw-r--r--abs/core-testing/libjpeg6/libjpeg6.install31
1 files changed, 31 insertions, 0 deletions
diff --git a/abs/core-testing/libjpeg6/libjpeg6.install b/abs/core-testing/libjpeg6/libjpeg6.install
new file mode 100644
index 0000000..dfb8ede
--- /dev/null
+++ b/abs/core-testing/libjpeg6/libjpeg6.install
@@ -0,0 +1,31 @@
+# arg 1: the new package version
+post_install() {
+ if qrep -q libjpeg6 /etc/ld.so.conf
+ then
+ exit
+ else
+ echo "/opt/libjpeg6/include" >> /etc/ld.so.conf
+ ldconfig
+ fi
+}
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ if qrep -q libjpeg6 /etc/ld.so.conf
+ then
+ exit
+ else
+ echo "/opt/libjpeg6/include" >> /etc/ld.so.conf
+ ldconfig
+ fi
+}
+# arg 1: the old package version
+post_remove() {
+ grep -v libjpeg6 /etc/ld.so.conf > /tmp/ld.so.conf
+ mv /tmp/ld.so.conf /etc/ld.so.conf
+ ldconfig
+}
+
+op=$1
+shift
+$op $*