summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/libxcb
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-01-16 06:05:04 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-01-16 06:05:04 (GMT)
commit38194ecb24d72258fd994cdb8aef7d34035c19b3 (patch)
treed82b9d2db6fe160295aa36837ce92e6960ddce1a /abs/core-testing/libxcb
parent7d87c5855f8b107fcc0f7f61956c60c6c8fdf53c (diff)
downloadlinhes_pkgbuild-38194ecb24d72258fd994cdb8aef7d34035c19b3.zip
linhes_pkgbuild-38194ecb24d72258fd994cdb8aef7d34035c19b3.tar.gz
linhes_pkgbuild-38194ecb24d72258fd994cdb8aef7d34035c19b3.tar.bz2
Fixed location of packages.
Diffstat (limited to 'abs/core-testing/libxcb')
-rw-r--r--abs/core-testing/libxcb/PKGBUILD37
-rw-r--r--abs/core-testing/libxcb/libxcb-1.1-no-pthread-stubs.patch12
-rw-r--r--abs/core-testing/libxcb/libxcb-1.1-sloppy-lock.patch12
3 files changed, 45 insertions, 16 deletions
diff --git a/abs/core-testing/libxcb/PKGBUILD b/abs/core-testing/libxcb/PKGBUILD
index b1eadee..c61df23 100644
--- a/abs/core-testing/libxcb/PKGBUILD
+++ b/abs/core-testing/libxcb/PKGBUILD
@@ -1,29 +1,34 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# $Id: PKGBUILD 8004 2008-08-05 18:11:40Z jgc $
# Maintainer: Alexander Baldeck <alexander@archlinux.org>
# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=libxcb
-pkgver=1.1
+pkgver=1.1.90.1
pkgrel=1
pkgdesc="X11 client-side library"
arch=(i686 x86_64)
url="http://xcb.freedesktop.org/"
-depends=('xcb-proto>=1.1' 'libxdmcp' 'libxau')
-makedepends=('pkgconfig' 'libxslt' 'libpthread-stubs')
+depends=('xcb-proto>=1.2' 'libxdmcp' 'libxau')
+makedepends=('pkgconfig' 'libxslt' 'python')
options=('!libtool')
license=('custom')
-source=(${url}/dist/${pkgname}-${pkgver}.tar.bz2)
+source=(${url}/dist/${pkgname}-${pkgver}.tar.bz2
+ libxcb-1.1-no-pthread-stubs.patch
+ libxcb-1.1-sloppy-lock.patch)
+md5sums=('c4b67c5576ed58e2fd4a2855c0b21aa6'
+ 'a53f09ab3ec5cbfc1b0848bd137c535a'
+ '4b3fbedc471d7ab336a18f1d0f853ddd')
build() {
- cd ${startdir}/src/${pkgname}-${pkgver}
- ./configure --prefix=/usr \
- --build=${CHOST} --host=${CHOST}
+ cd ${srcdir}/${pkgname}-${pkgver}
+ patch -Np1 -i ${srcdir}/libxcb-1.1-no-pthread-stubs.patch || return 1
+ patch -Np1 -i ${srcdir}/libxcb-1.1-sloppy-lock.patch || return 1
+ libtoolize --force --copy || return 1
+ aclocal || return 1
+ autoconf || return 1
+ automake --add-missing || return 1
+ ./configure --prefix=/usr --enable-xinput || return 1
make || return 1
- make DESTDIR=${startdir}/pkg install || return 1
- # Remove pthread-stubs dependency from pc files,
- # the stubs package doesn't provide any libs since our libc is complete.
- sed -i -e 's/pthread-stubs//' ${startdir}/pkg/usr/lib/pkgconfig/*.pc
-
- install -m644 -D ${startdir}/src/${pkgname}-${pkgver}/COPYING \
- ${startdir}/pkg/usr/share/licenses/${pkgname}/COPYING
+ make DESTDIR=${pkgdir} install || return 1
+ install -m755 -d ${pkgdir}/usr/share/licenses/${pkgname}
+ install -m644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/ || return 1
}
-md5sums=('9310b02433273d75d42f10da3c7455aa')
diff --git a/abs/core-testing/libxcb/libxcb-1.1-no-pthread-stubs.patch b/abs/core-testing/libxcb/libxcb-1.1-no-pthread-stubs.patch
new file mode 100644
index 0000000..67a09f2
--- /dev/null
+++ b/abs/core-testing/libxcb/libxcb-1.1-no-pthread-stubs.patch
@@ -0,0 +1,12 @@
+diff -up libxcb-1.1/configure.ac.pthread-stubs libxcb-1.1/configure.ac
+--- libxcb-1.1/configure.ac.pthread-stubs 2007-11-04 18:17:11.000000000 -0500
++++ libxcb-1.1/configure.ac 2007-11-12 10:27:06.000000000 -0500
+@@ -31,7 +31,7 @@ AC_SUBST(HTML_CHECK_RESULT)
+
+ # Checks for pkg-config packages
+ PKG_CHECK_MODULES(XCBPROTO, xcb-proto >= 1.1)
+-NEEDED="pthread-stubs xau >= 0.99.2"
++NEEDED="xau >= 0.99.2"
+ PKG_CHECK_MODULES(NEEDED, $NEEDED)
+
+ have_xdmcp="no"
diff --git a/abs/core-testing/libxcb/libxcb-1.1-sloppy-lock.patch b/abs/core-testing/libxcb/libxcb-1.1-sloppy-lock.patch
new file mode 100644
index 0000000..130890e
--- /dev/null
+++ b/abs/core-testing/libxcb/libxcb-1.1-sloppy-lock.patch
@@ -0,0 +1,12 @@
+diff -up libxcb-1.1/src/xcb_conn.c.jx libxcb-1.1/src/xcb_conn.c
+--- libxcb-1.1/src/xcb_conn.c.jx 2007-10-28 16:11:18.000000000 -0400
++++ libxcb-1.1/src/xcb_conn.c 2008-04-22 11:58:05.000000000 -0400
+@@ -63,7 +63,7 @@ static int _xcb_xlib_init(_xcb_xlib *xli
+ {
+ xlib->lock = 0;
+ #ifndef NDEBUG
+- xlib->sloppy_lock = (getenv("LIBXCB_ALLOW_SLOPPY_LOCK") != 0);
++ xlib->sloppy_lock = 1;
+ #endif
+ pthread_cond_init(&xlib->cond, 0);
+ return 1;