summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/libxml2/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-09-08 07:33:44 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-09-08 07:33:44 (GMT)
commit525753e4a1a139e088d8ac120b19fbab6c0aaaa6 (patch)
tree35cef28abb613da4f58e83f6abbe4bd4cfa244bf /abs/core-testing/libxml2/PKGBUILD
parent592e3cad43ef12c53f523145d0fd981b54f2a049 (diff)
parentb172f79fadb565ecfbcec9508f9377d8618a4f4c (diff)
downloadlinhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.zip
linhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.tar.gz
linhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/libxml2/PKGBUILD')
-rw-r--r--abs/core-testing/libxml2/PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/abs/core-testing/libxml2/PKGBUILD b/abs/core-testing/libxml2/PKGBUILD
index 8123cfc..d61e61e 100644
--- a/abs/core-testing/libxml2/PKGBUILD
+++ b/abs/core-testing/libxml2/PKGBUILD
@@ -1,22 +1,25 @@
-# $Id: PKGBUILD 26966 2009-02-14 23:57:37Z jgc $
+# $Id: PKGBUILD 73765 2010-03-28 13:12:08Z jgc $
# Maintainer: Jan de Groot <jgc@archlinux.org>
# Contributor: John Proctor <jproctor@prium.net>
pkgname=libxml2
-pkgver=2.7.3
+pkgver=2.7.7
pkgrel=1
pkgdesc="XML parsing library, version 2"
arch=(i686 x86_64)
license=('custom')
-depends=('zlib>=1.2.3.3' 'readline>=5.2.013' 'ncurses>=5.7')
+depends=('zlib>=1.2.4' 'readline>=6.1' 'ncurses>=5.7')
makedepends=('python')
options=('!libtool')
url="http://www.xmlsoft.org/"
-source=(ftp://ftp.xmlsoft.org/${pkgname}/${pkgname}-${pkgver}.tar.gz)
-md5sums=('8f4fda3969237c2a33bdb1583b5d06b2')
+source=(ftp://ftp.xmlsoft.org/${pkgname}/${pkgname}-${pkgver}.tar.gz
+ largefile64.patch)
+md5sums=('9abc9959823ca9ff904f1fbcf21df066'
+ '5ad4915665608ebfa5b89f7908467a72')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np1 -i "${srcdir}/largefile64.patch" || return 1
./configure --prefix=/usr --with-threads --with-history || return 1
make || return 1
make DESTDIR="${pkgdir}" install || return 1