summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/linhes-scripts/mythwelcome-config.py
diff options
context:
space:
mode:
authorGreg Frost <gregfrost1@bigpond.com>2010-04-18 05:55:06 (GMT)
committerGreg Frost <gregfrost1@bigpond.com>2010-04-18 05:55:06 (GMT)
commitd4589eee8998a168eaa79af7a04d82faac1a738d (patch)
tree731625204f3902bb9b5f7a8a492c6b8fcc09c915 /abs/core-testing/linhes-scripts/mythwelcome-config.py
parent5106977528d3d26919263bf62d504035a7720633 (diff)
parent787f13cd63c75c9c5090c10c0e888f48a59c0e49 (diff)
downloadlinhes_pkgbuild-d4589eee8998a168eaa79af7a04d82faac1a738d.zip
linhes_pkgbuild-d4589eee8998a168eaa79af7a04d82faac1a738d.tar.gz
linhes_pkgbuild-d4589eee8998a168eaa79af7a04d82faac1a738d.tar.bz2
Merge branch 'master' of ssh://gregfrost@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/linhes-scripts/mythwelcome-config.py')
-rwxr-xr-xabs/core-testing/linhes-scripts/mythwelcome-config.py27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/core-testing/linhes-scripts/mythwelcome-config.py b/abs/core-testing/linhes-scripts/mythwelcome-config.py
new file mode 100755
index 0000000..c7bf10b
--- /dev/null
+++ b/abs/core-testing/linhes-scripts/mythwelcome-config.py
@@ -0,0 +1,27 @@
+#!/usr/bin/env python
+
+# This script will configure the myth db to allow MythWelcome to wake and shutdown the system.
+
+from socket import gethostname
+from MythTV import MythDB
+mythdb = MythDB()
+localhostname = gethostname()
+
+# mythwelcome --setup
+mythdb.settings[localhostname].MythShutdownNvramCmd = u'sudo sh -c \"/usr/LH/bin/mythwelcome-set-alarm.sh $time\"'
+mythdb.settings[localhostname].MythShutdownWakeupTimeFmt = u'time_t'
+mythdb.settings[localhostname].MythShutdownNvramRestartCmd = u''
+mythdb.settings[localhostname].MythShutdownReboot = u'sudo /sbin/reboot'
+mythdb.settings[localhostname].MythShutdownPowerOff = u'sudo /sbin/poweroff'
+mythdb.settings[localhostname].MythShutdownXTermCmd = u'xterm'
+mythdb.settings[localhostname].MythWelcomeStartFECmd = u'/usr/LH/bin/mythfrontend-start'
+
+
+# mythtv-setup Shutdown/Wakeup options
+if mythdb.settings[localhostname].idleTimeoutSecs == u'0':
+ mythdb.settings[localhostname].idleTimeoutSecs = u'40'
+
+mythdb.settings.NULL.WakeupTimeFormat = u'yyyy-MM-ddThh:mm:ss'
+mythdb.settings.NULL.SetWakeuptimeCommand = u'/usr/bin/mythshutdown --setwakeup $time'
+mythdb.settings.NULL.ServerHaltCommand = u'/usr/bin/mythshutdown --shutdown'
+mythdb.settings.NULL.preSDWUCheckCommand = u'/usr/bin/mythshutdown --check'