summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/linhes-scripts/screenshooter.sh
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-08-21 00:52:37 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-08-21 00:52:37 (GMT)
commitd630a6ae3ada088453209270791ae281e2d5e393 (patch)
tree66692d1bf74042c24d7d38207ca80329d05210e6 /abs/core-testing/linhes-scripts/screenshooter.sh
parent1f99f4fab216bf9e580c70dd80a591ab3b908dfb (diff)
parentc85219e56fd07b11192ce28d605ee1cb24047914 (diff)
downloadlinhes_pkgbuild-d630a6ae3ada088453209270791ae281e2d5e393.zip
linhes_pkgbuild-d630a6ae3ada088453209270791ae281e2d5e393.tar.gz
linhes_pkgbuild-d630a6ae3ada088453209270791ae281e2d5e393.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
* 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD: mythtv-svn: fix pretty script dvb-fimware: bump so that I can build an ISO lirc: fix syntax error in lirc.fdi dvb-firmware:Added firmware for HVR 1600. LinHES-scripts:Updated screenshoot.sh to account for multiple dirs.
Diffstat (limited to 'abs/core-testing/linhes-scripts/screenshooter.sh')
-rwxr-xr-xabs/core-testing/linhes-scripts/screenshooter.sh15
1 files changed, 10 insertions, 5 deletions
diff --git a/abs/core-testing/linhes-scripts/screenshooter.sh b/abs/core-testing/linhes-scripts/screenshooter.sh
index 9e35786..94ea6fd 100755
--- a/abs/core-testing/linhes-scripts/screenshooter.sh
+++ b/abs/core-testing/linhes-scripts/screenshooter.sh
@@ -87,11 +87,16 @@ if [ ! -d "$VIDEO_CAPTURE_HOME" ] ; then
fi
VIDEO_HOME=$(mysql -u $DBUSERNAME --password=$DBPASSWORD -h $BACKEND_HOSTNAME mythconverg -sNBe "select data from settings where value='VideoStartupDir' limit 1")
-if [ ! -d "$VIDEO_HOME" ] ; then
- echo "Directory $VIDEO_HOME does not exist, nowhere to put the screen shot!"
- echo "Have you configured MythVideo yet?"
- exit 1
-fi
+VIDEO_HOME=(${VIDEO_HOME//:/ });
+VIDEO_HOME_COUNT=${#VIDEO_HOME[@]}
+for (( i=0; i<${VIDEO_HOME_COUNT}; i++ ));
+do
+ if [ ! -d "${VIDEO_HOME[${i}]}" ] ; then
+ echo "Directory ${VIDEO_HOME[${i}]} does not exist, nowhere to put the screen shot!"
+ echo "Have you configured MythVideo yet?"
+ exit 1
+ fi
+done
VIDEO_FILENAME=$(basename "$VIDEO_PATHNAME")
VIDEO_EXTENSION=${VIDEO_FILENAME##*.}