summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/linhes-scripts/src/importfiles.sh
diff options
context:
space:
mode:
authorGreg Frost <gregfrost1@bigpond.com>2009-08-04 01:22:18 (GMT)
committerGreg Frost <gregfrost1@bigpond.com>2009-08-04 01:22:18 (GMT)
commite85c92735d5ce5f790cf95a0ea02e08c264e170a (patch)
tree037a1921e8f6899fea9b5daaaf998ec746367298 /abs/core-testing/linhes-scripts/src/importfiles.sh
parent82af083e07eb189ac930678224a5748551cf69f8 (diff)
parent120212bdd438d98c52aaab5b43443258be81a7e4 (diff)
downloadlinhes_pkgbuild-e85c92735d5ce5f790cf95a0ea02e08c264e170a.zip
linhes_pkgbuild-e85c92735d5ce5f790cf95a0ea02e08c264e170a.tar.gz
linhes_pkgbuild-e85c92735d5ce5f790cf95a0ea02e08c264e170a.tar.bz2
Merge branch 'master' of ssh://gregfrost@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/linhes-scripts/src/importfiles.sh')
-rwxr-xr-xabs/core-testing/linhes-scripts/src/importfiles.sh18
1 files changed, 18 insertions, 0 deletions
diff --git a/abs/core-testing/linhes-scripts/src/importfiles.sh b/abs/core-testing/linhes-scripts/src/importfiles.sh
new file mode 100755
index 0000000..84f1ab5
--- /dev/null
+++ b/abs/core-testing/linhes-scripts/src/importfiles.sh
@@ -0,0 +1,18 @@
+#!/bin/bash
+export FONT="-adobe-helvetica-bold-*-*-*-34-*-*-*-*-*-*-*"
+
+DVD_or_CD=`cat /proc/mounts |grep iso9660|awk '{print $2}'|tail -1`
+if [ "$DVD_or_CD" != "" ]; then
+ echo "Copying files from $DVD_or_CD to /myth/video." > /tmp/screens
+ echo "This could take several minutes, depending on the" >> /tmp/screens
+ echo "speed and size of your optical media." >> /tmp/screens
+ cat /tmp/screens | osd_cat --font=$FONT --shadow=3 --pos=middle --align=centre --color=yellow --delay=0 &
+ /bin/cp -R $DVD_or_CD/* /myth/video/
+ killall osd_cat
+ echo "Copied videos from $DVD_or_CD to /myth/video" > /tmp/screens
+ cat /tmp/screens | osd_cat --font=$FONT --shadow=3 --pos=middle --align=centre --color=yellow --delay=2 &
+else
+ echo "No optical media found. If you just inserted" > /tmp/screens
+ echo "your media, please wait a moment and try again." >> /tmp/screens
+ cat /tmp/screens | osd_cat --font=$FONT --shadow=3 --pos=middle --align=centre --color=yellow --delay=5 &
+fi