summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/linhes-scripts/src/mythwelcome-test-wakeup.sh
diff options
context:
space:
mode:
authorGreg Frost <gregfrost1@bigpond.com>2009-08-04 01:22:18 (GMT)
committerGreg Frost <gregfrost1@bigpond.com>2009-08-04 01:22:18 (GMT)
commite85c92735d5ce5f790cf95a0ea02e08c264e170a (patch)
tree037a1921e8f6899fea9b5daaaf998ec746367298 /abs/core-testing/linhes-scripts/src/mythwelcome-test-wakeup.sh
parent82af083e07eb189ac930678224a5748551cf69f8 (diff)
parent120212bdd438d98c52aaab5b43443258be81a7e4 (diff)
downloadlinhes_pkgbuild-e85c92735d5ce5f790cf95a0ea02e08c264e170a.zip
linhes_pkgbuild-e85c92735d5ce5f790cf95a0ea02e08c264e170a.tar.gz
linhes_pkgbuild-e85c92735d5ce5f790cf95a0ea02e08c264e170a.tar.bz2
Merge branch 'master' of ssh://gregfrost@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/linhes-scripts/src/mythwelcome-test-wakeup.sh')
-rwxr-xr-xabs/core-testing/linhes-scripts/src/mythwelcome-test-wakeup.sh16
1 files changed, 16 insertions, 0 deletions
diff --git a/abs/core-testing/linhes-scripts/src/mythwelcome-test-wakeup.sh b/abs/core-testing/linhes-scripts/src/mythwelcome-test-wakeup.sh
new file mode 100755
index 0000000..4aadf6d
--- /dev/null
+++ b/abs/core-testing/linhes-scripts/src/mythwelcome-test-wakeup.sh
@@ -0,0 +1,16 @@
+#!/bin/sh
+
+sudo sh -c "echo 0 > /sys/class/rtc/rtc0/wakealarm" #this clears your alarm
+sudo sh -c "echo `date '+%s' -d '+ 4 minutes'` > /sys/class/rtc/rtc0/wakealarm" #this writes your alarm
+cat /proc/driver/rtc
+cat /proc/driver/rtc > /var/log/wake_alarm
+echo "Your computer is set to start up in 4 minutes using ACPI."
+echo -n "Do you want to shutdown the computer now? (y/n): "
+read -n 1 shutdown
+if [ "$shutdown" == "y" ]; then
+ echo -e "\nShutting down now..."
+ sudo shutdown -t 5 -h now
+else
+ echo -e "\nTo shutdown execute the following:"
+ echo " sudo shutdown -t 5 -h now"
+fi