summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mplayer/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-10-28 21:09:28 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-10-28 21:09:28 (GMT)
commitc848d1b444b9e03f047830c04f5e1e70183035e9 (patch)
treeff2e83339e0a73ad89a29c4f339045fb7c054952 /abs/core-testing/mplayer/PKGBUILD
parentc1381a8b3a355c57fca1ce2bfad0e3bf3e32b4ba (diff)
downloadlinhes_pkgbuild-c848d1b444b9e03f047830c04f5e1e70183035e9.zip
linhes_pkgbuild-c848d1b444b9e03f047830c04f5e1e70183035e9.tar.gz
linhes_pkgbuild-c848d1b444b9e03f047830c04f5e1e70183035e9.tar.bz2
move mplayer to testing
Diffstat (limited to 'abs/core-testing/mplayer/PKGBUILD')
-rw-r--r--abs/core-testing/mplayer/PKGBUILD67
1 files changed, 0 insertions, 67 deletions
diff --git a/abs/core-testing/mplayer/PKGBUILD b/abs/core-testing/mplayer/PKGBUILD
deleted file mode 100644
index f69a21a..0000000
--- a/abs/core-testing/mplayer/PKGBUILD
+++ /dev/null
@@ -1,67 +0,0 @@
-# $Id: PKGBUILD 3632 2008-06-26 11:48:49Z paul $
-# Maintainer: Thomas Bächler <thomas@archlinux.org>
-pkgname=mplayer
-pkgver=1.0rc2
-pkgrel=5
-pkgdesc="A movie player for linux"
-arch=(i686 x86_64)
-depends=('libxxf86dga' 'libxv' 'libmad' 'giflib' 'cdparanoia' 'gtk2'
- 'sdl' 'lame' 'libtheora' 'xvidcore'
- 'libgl' 'smbclient' 'aalib' 'jack-audio-connection-kit'
- 'x264>=20080625' 'faac' 'lirc-utils' 'ttf-dejavu')
-license=('GPL')
-url="http://www.mplayerhq.hu/"
-makedepends=('libcaca' 'unzip' 'live-media' 'libdca' 'mesa')
-backup=('etc/mplayer/codecs.conf' 'etc/mplayer/input.conf')
-source=(http://www.mplayerhq.hu/MPlayer/releases/MPlayer-${pkgver}.tar.bz2
- http://www.mplayerhq.hu/MPlayer/skins/Blue-1.7.tar.bz2
- http://www.mplayerhq.hu/MPlayer/patches/demux_audio_fix_20080129.diff
- http://www.mplayerhq.hu/MPlayer/patches/demux_mov_fix_20080129.diff
- http://www.mplayerhq.hu/MPlayer/patches/url_fix_20080120.diff
- http://www.mplayerhq.hu/MPlayer/patches/stream_cddb_fix_20080120.diff
- ivtv_2.6.24.patch)
-md5sums=('7e27e535c2d267637df34898f1b91707'
- 'e4e2020d11b681aac898103b3ba723c4'
- '320af7daa1b248ee8e8c15d34d7923e3'
- 'ce999929155f509a3e6bee41d9d613ed'
- '6a2c124586e1e6c44ae4ca1b4be9b6e4'
- 'c7d1bcdd61fcceb7598d61fe2213c587'
- '1ef35068587f6b6dbc99342567895236')
-
-build() {
- cd $startdir/src/MPlayer-${pkgver}
-
- # Custom CFLAGS break the mplayer build
- unset CFLAGS
-
- # Add support for gnome screensaver
- #patch -p1 -i ../MPlayer-1.0rc1-gnome-screensaver.patch || return 1
-
- # Workaround for changed ivtv interface since it went mainline in 2.6.24
- patch -p1 -i ../ivtv_2.6.24.patch || return 1
-
- # Fix security issues
- for p in demux_audio_fix_20080129.diff demux_mov_fix_20080129.diff url_fix_20080120.diff stream_cddb_fix_20080120.diff; do
- patch -p0 -i ../${p}
- done
-
- cd $startdir/src/MPlayer-${pkgver}
-
- ./configure --prefix=/usr --enable-gui --disable-arts --enable-x11 \
- --enable-runtime-cpudetection --confdir=/etc/mplayer --disable-nas \
- --enable-gl --enable-tv-v4l1 --enable-tv-v4l2 --enable-largefiles \
- --disable-liblzo --disable-speex --disable-openal \
- --disable-fribidi --disable-libdv --disable-musepack \
- --language=all --disable-dvdnav --disable-esd --disable-mga \
- --disable-libamr_nb \
- --with-extraincdir=/usr/lib/live-media
-
- [ "$CARCH" = "i686" ] && sed 's|-march=i486|-march=i686|g' -i config.mak
-
- make || return 1
- make -j1 DESTDIR=${startdir}/pkg install
- cp etc/{codecs.conf,input.conf,example.conf} ${startdir}/pkg/etc/mplayer/
- ln -s /usr/share/fonts/TTF/DejaVuSans.ttf ${startdir}/pkg/usr/share/mplayer/subfont.ttf
- rm -rf ${startdir}/pkg/usr/share/mplayer/font
- mv ${startdir}/src/Blue ${startdir}/pkg/usr/share/mplayer/skins/default
-}