summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythinstall/installsettings.cpp
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-08-30 14:52:42 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-08-30 14:52:42 (GMT)
commit39f7114420e01a1ee8cae488164ff2ab3504350a (patch)
tree7390c2303fe547544fa1ac45d8dfda2086b49ee3 /abs/core-testing/mythinstall/installsettings.cpp
parent7c38541dbbbead64f04641065ab038ed545190bd (diff)
parent3aef682afa6426e44abaceb56e510af8dcf7bd94 (diff)
downloadlinhes_pkgbuild-39f7114420e01a1ee8cae488164ff2ab3504350a.zip
linhes_pkgbuild-39f7114420e01a1ee8cae488164ff2ab3504350a.tar.gz
linhes_pkgbuild-39f7114420e01a1ee8cae488164ff2ab3504350a.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
* 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD: rrdtool: add ruby dep to resolve RRD.so dependency python-netifaces: chmod -x on info files xulrunner: add libs to ld.so.conf in install script perl-text-kakasi: fix kakasi dependency pyorbit: rebuild to fix libpython2.5.so.1.0 => not found xine-lib: upgrade to 1.1.16.3 and rebuild to fix missing shared lib references local-website:updated link for f@h. Folding@Home:Updates for webpage. foldingathome:bump. gd:bump for libjpeg foldingathome: change location to /myth/foldingathome/ shepherd: update to latest from http://www.whuffy.com/shepherd/shepherd foldingathome: git add run script LinHES-config mythinstall foldingathome: initial inclusion of Folding@home
Diffstat (limited to 'abs/core-testing/mythinstall/installsettings.cpp')
-rwxr-xr-xabs/core-testing/mythinstall/installsettings.cpp72
1 files changed, 67 insertions, 5 deletions
diff --git a/abs/core-testing/mythinstall/installsettings.cpp b/abs/core-testing/mythinstall/installsettings.cpp
index 7315464..3942460 100755
--- a/abs/core-testing/mythinstall/installsettings.cpp
+++ b/abs/core-testing/mythinstall/installsettings.cpp
@@ -1277,6 +1277,62 @@ static HostCheckBox *Hostfuppes()
return gc;
};
+static HostCheckBox *Hostfoldingathome()
+{
+ HostCheckBox *gc = new HostCheckBox("Hostfoldingathome");
+ gc->setLabel(QObject::tr("Folding@home"));
+ gc->setValue(false);
+ gc->setHelpText(QObject::tr("A distributed computing project which studies protein folding, misfolding, aggregation, and related diseases."));
+ return gc;
+};
+
+static HostComboBox *Hostfoldingusername()
+{
+ // If there is an old R5.5 style folding directory /myth/folding@home, attempt
+ // to retrieve the old username.
+
+ FILE *username_pipe;
+ username_pipe =
+ popen (
+ "grep username= /myth/folding@home/client.cfg 2> /dev/null | "
+ "sed 's/username=//g'", "r");
+
+ if (username_pipe)
+ {
+ char username[200];
+ if (fgets (username, sizeof (username), username_pipe))
+ {
+ char *new_line;
+ username[sizeof(username)-1]=0;
+ if ((new_line = strchr (username, '\n')))
+ new_line[0] = 0;
+
+ cout << "found old username " << username << endl;
+
+ gContext->SetSetting("Hostfoldingusername", username);
+ gContext->SaveSetting("Hostfoldingusername", username);
+ }
+ pclose (username_pipe);
+ }
+
+ HostComboBox *gc = new HostComboBox("Hostfoldingusername",true);
+ gc->setLabel(QObject::tr("Folding Username"));
+ gc->setValue("");
+
+ gc->setHelpText(QObject::tr("The username associated to the work-units you return."));
+ return gc;
+};
+
+static HostComboBox *Hostfoldingworksize()
+{
+ HostComboBox *gc = new HostComboBox("Hostfoldingworksize");
+ gc->setLabel(QObject::tr("Work Packet Size"));
+ gc->addSelection("Big", "big");
+ gc->addSelection("Normal", "normal");
+ gc->addSelection("Small", "small");
+ gc->setHelpText(QObject::tr("Acceptable size of work assignment and work result packets (bigger units may have large memory demands)."));
+ return gc;
+};
static HostCheckBox *HostXscreensaver()
{
@@ -3880,6 +3936,9 @@ void writesettings ()
hostparm.ThisHostXine = gContext->GetSetting("HostXine");
hostparm.ThisHostwebmin = gContext->GetSetting("Hostwebmin");
hostparm.ThisHostfuppes = gContext->GetSetting("Hostfuppes");
+ hostparm.ThisHostfoldingathome = gContext->GetSetting("Hostfoldingathome");
+ hostparm.ThisHostfoldingusername = gContext->GetSetting("Hostfoldingusername");
+ hostparm.ThisHostfoldingworksize = gContext->GetSetting("Hostfoldingworksize");
hostparm.ThisHostDDnslogin = gContext->GetSetting("HostDDnslogin");
hostparm.ThisHostDDnspassword = gContext->GetSetting("HostDDnspassword");
hostparm.ThisHostDDnshostname = gContext->GetSetting("HostDDnshostname");
@@ -4124,7 +4183,9 @@ void writesettings ()
myfile << "xine=\"" + hostparm.ThisHostXine + "\"\n";
myfile << "webmin=\"" + hostparm.ThisHostwebmin + "\"\n";
myfile << "fuppes=\"" + hostparm.ThisHostfuppes + "\"\n";
-
+ myfile << "foldingathome=\"" + hostparm.ThisHostfoldingathome + "\"\n";
+ myfile << "foldingusername=\"" + hostparm.ThisHostfoldingusername + "\"\n";
+ myfile << "foldingworksize=\"" + hostparm.ThisHostfoldingworksize + "\"\n";
@@ -4378,6 +4439,10 @@ MythInstallSettings::MythInstallSettings()
ConfigurationGroup *GridShowPlugin5 = new GridConfigurationGroup(2);
GridShowPlugin5->addChild(Hostfuppes());
+ ConfigurationGroup *GridShowPlugin6 = new VerticalConfigurationGroup(true,true);
+ GridShowPlugin6->addChild(Hostfoldingathome());
+ GridShowPlugin6->addChild(Hostfoldingusername());
+ GridShowPlugin6->addChild(Hostfoldingworksize());
ConfigurationGroup *Mythvideoplugin = new HorizontalConfigurationGroup();
Mythvideoplugin->addChild(Hostpluginmythvideo());
@@ -4395,6 +4460,7 @@ MythInstallSettings::MythInstallSettings()
addChild(GridShowPlugin3);
addChild(GridShowPlugin4);
addChild(GridShowPlugin5);
+ addChild(GridShowPlugin6);
}
}
if ( displayuser )
@@ -4475,7 +4541,3 @@ MythInstallSettings::MythInstallSettings()
};
-
-
-
-