summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythinstall/mythinstall.pro
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-08-02 04:36:08 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-08-02 04:36:08 (GMT)
commit9a4b520578e61b098b4dce7a3ba2376c0c74b01e (patch)
tree0b77dde997c3554e8211e386485ddc1199ecc476 /abs/core-testing/mythinstall/mythinstall.pro
parent68f0ad93db42767b17f0c9187354b3f0533e896c (diff)
parent657aa7b8d352108a98719a22e6422b490e598d26 (diff)
downloadlinhes_pkgbuild-9a4b520578e61b098b4dce7a3ba2376c0c74b01e.zip
linhes_pkgbuild-9a4b520578e61b098b4dce7a3ba2376c0c74b01e.tar.gz
linhes_pkgbuild-9a4b520578e61b098b4dce7a3ba2376c0c74b01e.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/mythinstall/mythinstall.pro')
-rwxr-xr-xabs/core-testing/mythinstall/mythinstall.pro46
1 files changed, 46 insertions, 0 deletions
diff --git a/abs/core-testing/mythinstall/mythinstall.pro b/abs/core-testing/mythinstall/mythinstall.pro
new file mode 100755
index 0000000..0a273cc
--- /dev/null
+++ b/abs/core-testing/mythinstall/mythinstall.pro
@@ -0,0 +1,46 @@
+# This is the path to the mythtv src. The assumtion is that this package and
+# mythtv are both being build in the LinHES-PKGBUILD.
+MYTHPATH="/data/LinHES-PKGBUILD/abs/core-testing/mythtv/stable/mythtv/src/mythtv-0.21"
+
+include ( $$MYTHPATH/libs/libmyth/mythconfig.mak)
+include ( $$MYTHPATH/settings.pro)
+
+#pulled from program-libs.pro and modified to use $$MYTHPATH
+INCLUDEPATH += $$MYTHPATH $$MYTHPATH/libs/ $$MYTHPATH/libs/libmyth $$MYTHPATH/libs/libmythtv
+INCLUDEPATH += $$MYTHPATH/libs/libavutil $$MYTHPATH/libs/libavformat $$MYTHPATH/libs/libavcodec
+INCLUDEPATH += $$MYTHPATH/libs/libmythupnp $$MYTHPATH/libs/libmythui
+INCLUDEPATH += $$MYTHPATH/libs/libmythlivemedia
+
+LIBS += -L$$MYTHPATH/libs/libmyth -L$$MYTHPATH/libs/libmythtv
+LIBS += -L$$MYTHPATH/libs/libavutil -L$$MYTHPATH/libs/libavcodec -L$$MYTHPATH/libs/libavformat
+LIBS += -L$$MYTHPATH/libs/libmythfreemheg
+LIBS += -L$$MYTHPATH/libs/libmythui
+LIBS += -L$$MYTHPATH/libs/libmythupnp
+LIBS += -L$$MYTHPATH/libs/libmythlivemedia
+
+LIBS += -lmythtv-$$LIBVERSION -lmythavformat-$$LIBVERSION
+LIBS += -lmythavutil-$$LIBVERSION -lmythavcodec-$$LIBVERSION
+LIBS += -lmythfreemheg-$$LIBVERSION
+LIBS += -lmythupnp-$$LIBVERSION
+LIBS += -lmythlivemedia-$$LIBVERSION
+
+
+
+TEMPLATE = app
+CONFIG += thread
+TARGET = mythinstall
+target.path = $${PREFIX}/bin
+
+INSTALLS = target
+
+uifiles.path = $${PREFIX}/share/mythtv/themes/default
+uifiles.files = install-ui.xml images/*.png
+
+INSTALLS += uifiles
+
+QMAKE_CLEAN += $(TARGET)
+
+# Input
+HEADERS += installdialog.h installsettings.h settemplate.h installationtype.h autocard.h xorgsettings.h password_manage.h misc_settings.h mv_common.h infrared.h
+SOURCES += main.cpp installdialog.cpp installsettings.cpp settemplate.cpp installationtype.cpp autocard.cpp xorgsettings.cpp password_manage.cpp misc_settings.cpp infrared.cpp
+INCLUDEPATH += /usr/include/mythtv