summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythinstall
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-09-08 14:30:08 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-09-08 14:30:08 (GMT)
commitfc7e1cd23de947c5ef6fcbb06561038f610b055f (patch)
treec548e96db39ed2048c65b8565181b628d3239370 /abs/core-testing/mythinstall
parent8beb20649824b0bc50d953e11a6d49f01a76cace (diff)
parentba38d110a556bc739c6306b4ecdb0c2765d15deb (diff)
downloadlinhes_pkgbuild-fc7e1cd23de947c5ef6fcbb06561038f610b055f.zip
linhes_pkgbuild-fc7e1cd23de947c5ef6fcbb06561038f610b055f.tar.gz
linhes_pkgbuild-fc7e1cd23de947c5ef6fcbb06561038f610b055f.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
* 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD: Fuppes:bumped to compile latest. mytharchive:bumped to compile latest. fuppes:Added logrotation. udev:modified usb-storage rule to cleanly unmount. Local-website:Added zoneminder. ZoneMinder:Further enhancements to run on LinHES. zoneminder:bumped to recompile for ffmpeg-svn. LinHES-config:Added mythzoneminder. MythInstall:Added MythZoneMinder to list of installable software. Zoneminder:Changes needed to run on LinHES. PHP: Updated md5sum for php.ini. PHP:Changes to php.ini for Zoneminder. scanfw scte65scan: initial inclusion MythAppleTrailers:Fixes the URL change.
Diffstat (limited to 'abs/core-testing/mythinstall')
-rw-r--r--abs/core-testing/mythinstall/PKGBUILD2
-rwxr-xr-xabs/core-testing/mythinstall/installsettings.cpp13
-rwxr-xr-xabs/core-testing/mythinstall/installsettings.h1
3 files changed, 15 insertions, 1 deletions
diff --git a/abs/core-testing/mythinstall/PKGBUILD b/abs/core-testing/mythinstall/PKGBUILD
index c614fac..5a936da 100644
--- a/abs/core-testing/mythinstall/PKGBUILD
+++ b/abs/core-testing/mythinstall/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jams
pkgname=mythinstall
pkgver=1
-pkgrel=10
+pkgrel=11
pkgdesc="LinHES installer/systemconfig GUI."
arch=i686
depends=()
diff --git a/abs/core-testing/mythinstall/installsettings.cpp b/abs/core-testing/mythinstall/installsettings.cpp
index 3942460..0a6afb5 100755
--- a/abs/core-testing/mythinstall/installsettings.cpp
+++ b/abs/core-testing/mythinstall/installsettings.cpp
@@ -1344,6 +1344,16 @@ static HostCheckBox *HostXscreensaver()
};
+static HostCheckBox *Hostpluginmythzoneminder()
+{
+ HostCheckBox *gc = new HostCheckBox("Hostpluginmythzoneminder");
+ gc->setLabel(QObject::tr("mythzoneminder"));
+ gc->setValue(false);
+ gc->setHelpText(QObject::tr("check to enable mythzoneminder"));
+ return gc;
+};
+
+
// -------------End plugins--------------------------------
@@ -3923,6 +3933,7 @@ void writesettings ()
hostparm.ThisHostpluginmythsmolt = gContext->GetSetting("Hostpluginmythsmolt");
hostparm.ThisHostpluginmythvideo = gContext->GetSetting("Hostpluginmythvideo");
hostparm.ThisHostpluginmythweather = gContext->GetSetting("Hostpluginmythweather");
+ hostparm.ThisHostpluginmythzoneminder = gContext->GetSetting("Hostpluginmythzoneminder");
hostparm.ThisHostpluginmythgameFceu = gContext->GetSetting("HostpluginmythgameFceu");
hostparm.ThisHostpluginmythgameZsnes = gContext->GetSetting("HostpluginmythgameZsnes");
hostparm.ThisHostpluginmythgameMame = gContext->GetSetting("HostpluginmythgameMame");
@@ -4168,6 +4179,7 @@ void writesettings ()
myfile << "mythsmolt=\"" + hostparm.ThisHostpluginmythsmolt + "\"\n";
myfile << "mythvideo=\"" + hostparm.ThisHostpluginmythvideo + "\"\n";
myfile << "mythweather=\"" + hostparm.ThisHostpluginmythweather + "\"\n";
+ myfile << "mythzoneminder=\"" + hostparm.ThisHostpluginmythzoneminder + "\"\n";
myfile << "fceu=\"" + hostparm.ThisHostpluginmythgameFceu + "\"\n";
myfile << "zsnes=\"" + hostparm.ThisHostpluginmythgameZsnes + "\"\n";
@@ -4427,6 +4439,7 @@ MythInstallSettings::MythInstallSettings()
GridShowPlugin2->addChild(Hostpluginmythphone());
GridShowPlugin2->addChild(Hostpluginmythsmolt());
GridShowPlugin2->addChild(Hostpluginmythweather());
+ GridShowPlugin2->addChild(Hostpluginmythzoneminder());
ConfigurationGroup *GridShowPlugin4 = new GridConfigurationGroup(2);
GridShowPlugin4->addChild(Hostpluginmythappletrailers());
diff --git a/abs/core-testing/mythinstall/installsettings.h b/abs/core-testing/mythinstall/installsettings.h
index c140f3d..a177921 100755
--- a/abs/core-testing/mythinstall/installsettings.h
+++ b/abs/core-testing/mythinstall/installsettings.h
@@ -442,6 +442,7 @@ struct HostParms
QString ThisHostpluginmythsmolt;
QString ThisHostpluginmythvideo;
QString ThisHostpluginmythweather;
+ QString ThisHostpluginmythzoneminder;
QString ThisHostpluginmythgameFceu;
QString ThisHostpluginmythgameZsnes;
QString ThisHostpluginmythgameMame;