summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/old/stable-0.21/mythdb-initial/mythdb.install
diff options
context:
space:
mode:
authorGreg Frost <gregfrost1@bigpond.com>2010-01-03 09:31:13 (GMT)
committerGreg Frost <gregfrost1@bigpond.com>2010-01-03 09:31:13 (GMT)
commit1bc00e917b6d425eebd674bcbd977468662b0888 (patch)
treeb433f52b95e973058fd6fdfaac6052763f259544 /abs/core-testing/mythtv/old/stable-0.21/mythdb-initial/mythdb.install
parent41379ca92b7d3806883a6e40cb487cff0c9b4ba0 (diff)
parent6d63c414bf8405d601fcb5ee90035b8ca8664e86 (diff)
downloadlinhes_pkgbuild-1bc00e917b6d425eebd674bcbd977468662b0888.zip
linhes_pkgbuild-1bc00e917b6d425eebd674bcbd977468662b0888.tar.gz
linhes_pkgbuild-1bc00e917b6d425eebd674bcbd977468662b0888.tar.bz2
Merge branch 'master' of ssh://gregfrost@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/mythtv/old/stable-0.21/mythdb-initial/mythdb.install')
-rwxr-xr-xabs/core-testing/mythtv/old/stable-0.21/mythdb-initial/mythdb.install31
1 files changed, 31 insertions, 0 deletions
diff --git a/abs/core-testing/mythtv/old/stable-0.21/mythdb-initial/mythdb.install b/abs/core-testing/mythtv/old/stable-0.21/mythdb-initial/mythdb.install
new file mode 100755
index 0000000..4834c69
--- /dev/null
+++ b/abs/core-testing/mythtv/old/stable-0.21/mythdb-initial/mythdb.install
@@ -0,0 +1,31 @@
+mydate=`date +%m-%d-%y`
+HOST=`hostname`
+post_install() {
+#echo backup the old database
+ mysqldump mythconverg >/data/database/mythconverg.${mydate}.sql
+# echo dropping the old database
+ mysql -u root -e 'drop database mythconverg;'
+ mysql -u root -e 'create database mythconverg;'
+ echo installing the default database
+ if [ $HOST = 'larch5' ]
+ then
+ cp /data/database/mc.sql.initial /data/database/mc.sql.fixed
+ cp /data/database/permissions.sql /data/database/permissions.sql.fixed
+ else
+ sed -e "s/larch5/$HOST/g" /data/database/mc.sql.initial > /data/database/mc.sql.fixed
+ sed -e "s/larch5/$HOST/g" /data/database/permissions.sql > /data/database/permissions.sql.fixed
+
+ fi
+
+ mysql mythconverg < /data/database/mc.sql.fixed 2>/dev/null
+ mysql < /data/database/permissions.sql.fixed 2>/dev/null
+
+ rm /data/database/mc.sql.initial
+}
+post_upgrade() {
+ echo "nothing to do"
+}
+
+op=$1
+shift
+$op $*