summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/old/stable-0.21/mythsmolt/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2010-01-01 18:25:44 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2010-01-01 18:25:44 (GMT)
commit6f5a7459a4127507c578cc22b8ae24550a45e123 (patch)
tree3aa68b61ad25846d919751959c7cd4e54ce2ce70 /abs/core-testing/mythtv/old/stable-0.21/mythsmolt/PKGBUILD
parent0b90a77e47c10ae4ba815122b0735bc74fba89ea (diff)
downloadlinhes_pkgbuild-6f5a7459a4127507c578cc22b8ae24550a45e123.zip
linhes_pkgbuild-6f5a7459a4127507c578cc22b8ae24550a45e123.tar.gz
linhes_pkgbuild-6f5a7459a4127507c578cc22b8ae24550a45e123.tar.bz2
Cleaning up the tree...
Diffstat (limited to 'abs/core-testing/mythtv/old/stable-0.21/mythsmolt/PKGBUILD')
-rw-r--r--abs/core-testing/mythtv/old/stable-0.21/mythsmolt/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/core-testing/mythtv/old/stable-0.21/mythsmolt/PKGBUILD b/abs/core-testing/mythtv/old/stable-0.21/mythsmolt/PKGBUILD
new file mode 100644
index 0000000..25c91cf
--- /dev/null
+++ b/abs/core-testing/mythtv/old/stable-0.21/mythsmolt/PKGBUILD
@@ -0,0 +1,26 @@
+pkgname=mythsmolt
+pkgver=0.21
+pkgrel=8
+pkgdesc="mythsmolt, a hardware profileing tool"
+arch=('i686' 'x86_64')
+url="http://www.mythvantage.com"
+license=('GPL')
+depends=("mythtv>=${pkgver}" urlgrabber)
+source=("http://www.mythvantage.com/request.php?4")
+
+groups=('mythtv-extras')
+
+build() {
+ cd $startdir/src/mythsmolt_src/mythsmolt
+ . /etc/profile.d/qt3.sh
+
+ # use QT3 qmake
+ export PATH=$QTDIR/bin:$PATH
+ echo "INCLUDEPATH += /usr/include/mythtv" >> mythsmolt.pro.usr
+
+ qmake mythsmolt.pro.usr
+ make qmake || return 1
+ make -j 2 || return 1
+
+ make INSTALL_ROOT=$startdir/pkg install
+}