summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/old/stable-0.21/mythsmolt/PKGBUILD
diff options
context:
space:
mode:
authorGreg Frost <gregfrost1@bigpond.com>2010-01-03 09:31:13 (GMT)
committerGreg Frost <gregfrost1@bigpond.com>2010-01-03 09:31:13 (GMT)
commit1bc00e917b6d425eebd674bcbd977468662b0888 (patch)
treeb433f52b95e973058fd6fdfaac6052763f259544 /abs/core-testing/mythtv/old/stable-0.21/mythsmolt/PKGBUILD
parent41379ca92b7d3806883a6e40cb487cff0c9b4ba0 (diff)
parent6d63c414bf8405d601fcb5ee90035b8ca8664e86 (diff)
downloadlinhes_pkgbuild-1bc00e917b6d425eebd674bcbd977468662b0888.zip
linhes_pkgbuild-1bc00e917b6d425eebd674bcbd977468662b0888.tar.gz
linhes_pkgbuild-1bc00e917b6d425eebd674bcbd977468662b0888.tar.bz2
Merge branch 'master' of ssh://gregfrost@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/mythtv/old/stable-0.21/mythsmolt/PKGBUILD')
-rw-r--r--abs/core-testing/mythtv/old/stable-0.21/mythsmolt/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/core-testing/mythtv/old/stable-0.21/mythsmolt/PKGBUILD b/abs/core-testing/mythtv/old/stable-0.21/mythsmolt/PKGBUILD
new file mode 100644
index 0000000..25c91cf
--- /dev/null
+++ b/abs/core-testing/mythtv/old/stable-0.21/mythsmolt/PKGBUILD
@@ -0,0 +1,26 @@
+pkgname=mythsmolt
+pkgver=0.21
+pkgrel=8
+pkgdesc="mythsmolt, a hardware profileing tool"
+arch=('i686' 'x86_64')
+url="http://www.mythvantage.com"
+license=('GPL')
+depends=("mythtv>=${pkgver}" urlgrabber)
+source=("http://www.mythvantage.com/request.php?4")
+
+groups=('mythtv-extras')
+
+build() {
+ cd $startdir/src/mythsmolt_src/mythsmolt
+ . /etc/profile.d/qt3.sh
+
+ # use QT3 qmake
+ export PATH=$QTDIR/bin:$PATH
+ echo "INCLUDEPATH += /usr/include/mythtv" >> mythsmolt.pro.usr
+
+ qmake mythsmolt.pro.usr
+ make qmake || return 1
+ make -j 2 || return 1
+
+ make INSTALL_ROOT=$startdir/pkg install
+}