summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/old/stable-0.21/mythstream/mythstream.install
diff options
context:
space:
mode:
authorGreg Frost <gregfrost1@bigpond.com>2010-01-03 09:31:13 (GMT)
committerGreg Frost <gregfrost1@bigpond.com>2010-01-03 09:31:13 (GMT)
commit1bc00e917b6d425eebd674bcbd977468662b0888 (patch)
treeb433f52b95e973058fd6fdfaac6052763f259544 /abs/core-testing/mythtv/old/stable-0.21/mythstream/mythstream.install
parent41379ca92b7d3806883a6e40cb487cff0c9b4ba0 (diff)
parent6d63c414bf8405d601fcb5ee90035b8ca8664e86 (diff)
downloadlinhes_pkgbuild-1bc00e917b6d425eebd674bcbd977468662b0888.zip
linhes_pkgbuild-1bc00e917b6d425eebd674bcbd977468662b0888.tar.gz
linhes_pkgbuild-1bc00e917b6d425eebd674bcbd977468662b0888.tar.bz2
Merge branch 'master' of ssh://gregfrost@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/mythtv/old/stable-0.21/mythstream/mythstream.install')
-rw-r--r--abs/core-testing/mythtv/old/stable-0.21/mythstream/mythstream.install23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/core-testing/mythtv/old/stable-0.21/mythstream/mythstream.install b/abs/core-testing/mythtv/old/stable-0.21/mythstream/mythstream.install
new file mode 100644
index 0000000..5af96f2
--- /dev/null
+++ b/abs/core-testing/mythtv/old/stable-0.21/mythstream/mythstream.install
@@ -0,0 +1,23 @@
+# arg 1: the new package version
+post_install() {
+ mv /usr/share/mythtv/is.xml /tmp
+ grep -v -e /mythmenu /tmp/is.xml > /tmp/is.xml.tmp
+ echo "<!--#MythStream-->" >> /tmp/is.xml.tmp
+ echo " <button>" >> /tmp/is.xml.tmp
+ echo " <type>STREAM</type>" >> /tmp/is.xml.tmp
+ echo " <text>MythStream</text>" >> /tmp/is.xml.tmp
+ echo " <action>PLUGIN mythstream</action>" >> /tmp/is.xml.tmp
+ echo " </button>" >> /tmp/is.xml.tmp
+ echo "<!--#MythStream-->" >> /tmp/is.xml.tmp
+ echo "" >> /tmp/is.xml.tmp
+ echo "</mythmenu>" >> /tmp/is.xml.tmp
+ mv /tmp/is.xml.tmp /usr/share/mythtv/is.xml
+}
+post_remove() {
+ mv /usr/share/mythtv/is.xml /tmp/is.xml.tmp
+ sed -e '/\#MythStream/,/\#MythStream/d' < /tmp/is.xml.tmp > /usr/share/mythtv/is.xml
+}
+
+op=$1
+shift
+$op $*