summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/old/stable-0.21/mythvideo/PKGBUILD
diff options
context:
space:
mode:
authorGreg Frost <gregfrost1@bigpond.com>2010-01-03 09:31:13 (GMT)
committerGreg Frost <gregfrost1@bigpond.com>2010-01-03 09:31:13 (GMT)
commit1bc00e917b6d425eebd674bcbd977468662b0888 (patch)
treeb433f52b95e973058fd6fdfaac6052763f259544 /abs/core-testing/mythtv/old/stable-0.21/mythvideo/PKGBUILD
parent41379ca92b7d3806883a6e40cb487cff0c9b4ba0 (diff)
parent6d63c414bf8405d601fcb5ee90035b8ca8664e86 (diff)
downloadlinhes_pkgbuild-1bc00e917b6d425eebd674bcbd977468662b0888.zip
linhes_pkgbuild-1bc00e917b6d425eebd674bcbd977468662b0888.tar.gz
linhes_pkgbuild-1bc00e917b6d425eebd674bcbd977468662b0888.tar.bz2
Merge branch 'master' of ssh://gregfrost@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/mythtv/old/stable-0.21/mythvideo/PKGBUILD')
-rw-r--r--abs/core-testing/mythtv/old/stable-0.21/mythvideo/PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/abs/core-testing/mythtv/old/stable-0.21/mythvideo/PKGBUILD b/abs/core-testing/mythtv/old/stable-0.21/mythvideo/PKGBUILD
new file mode 100644
index 0000000..a233549
--- /dev/null
+++ b/abs/core-testing/mythtv/old/stable-0.21/mythvideo/PKGBUILD
@@ -0,0 +1,41 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Juergen Hoetzel <travis@archlinux.org>
+# Contributor: kleptophobiac@gmail.com
+
+pkgname=mythvideo
+pkgver=0.21
+pkgrel=9
+pkgdesc="Video playback and browsing plugin for MythTV"
+arch=('i686' 'x86_64')
+url="http://www.mythtv.org"
+license=('GPL')
+depends=("mythtv>=${pkgver}" 'mplayer' 'perlxml' 'perl-libwww' 'perl-uri' 'perl-xml-simple' 'ffmpeg')
+source=("ftp://ftp.knoppmyth.net/R6/sources/mythplugins-$pkgver-fixes.tar.bz2"\
+ "ftp://ftp.knoppmyth.net/R6/sources/tmdb.tar.bz2" \
+ mtd mythvideo-6338-use_tmdb_in_fixes.patch)
+md5sums=('1b3e2a97b7ecf7373e162fe20b6faabe' '48cff8f7095586c85ec70989746736b4' '476c12ba074794ad7f4ae092bdf949d6' '4bd38d054dfc4b0b1724f398d38676f7')
+replaces=('mythdvd')
+groups=('mythtv-extras')
+install=mythvideo.install
+
+build() {
+ cd $startdir/src/mythplugins
+ svn update
+ patch -p1 < ../mythvideo-6338-use_tmdb_in_fixes.patch
+ . /etc/profile.d/qt3.sh
+
+ # use QT3 qmake
+ export PATH=$QTDIR/bin:$PATH
+
+ ./configure --prefix=/usr --disable-all --enable-mythvideo
+
+ qmake mythplugins.pro
+ make qmake || return 1
+ make -j 2 || return 1
+
+ make INSTALL_ROOT=$startdir/pkg install
+ install -D -m755 ../mtd $startdir/pkg/etc/rc.d/mtd
+ cp -Rv $startdir/src/tmdb/* $startdir/pkg/usr/share/mythtv/mythvideo/scripts/
+}
+
+