summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/old/stable-0.21/mythweb/patch/mythweb.pl.diff
diff options
context:
space:
mode:
authorGreg Frost <gregfrost1@bigpond.com>2010-01-03 09:31:13 (GMT)
committerGreg Frost <gregfrost1@bigpond.com>2010-01-03 09:31:13 (GMT)
commit1bc00e917b6d425eebd674bcbd977468662b0888 (patch)
treeb433f52b95e973058fd6fdfaac6052763f259544 /abs/core-testing/mythtv/old/stable-0.21/mythweb/patch/mythweb.pl.diff
parent41379ca92b7d3806883a6e40cb487cff0c9b4ba0 (diff)
parent6d63c414bf8405d601fcb5ee90035b8ca8664e86 (diff)
downloadlinhes_pkgbuild-1bc00e917b6d425eebd674bcbd977468662b0888.zip
linhes_pkgbuild-1bc00e917b6d425eebd674bcbd977468662b0888.tar.gz
linhes_pkgbuild-1bc00e917b6d425eebd674bcbd977468662b0888.tar.bz2
Merge branch 'master' of ssh://gregfrost@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/mythtv/old/stable-0.21/mythweb/patch/mythweb.pl.diff')
-rw-r--r--abs/core-testing/mythtv/old/stable-0.21/mythweb/patch/mythweb.pl.diff23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/core-testing/mythtv/old/stable-0.21/mythweb/patch/mythweb.pl.diff b/abs/core-testing/mythtv/old/stable-0.21/mythweb/patch/mythweb.pl.diff
new file mode 100644
index 0000000..6dcbf99
--- /dev/null
+++ b/abs/core-testing/mythtv/old/stable-0.21/mythweb/patch/mythweb.pl.diff
@@ -0,0 +1,23 @@
+*** mythweb-unpatched.pl 2009-06-02 14:55:24.011861459 -0400
+--- mythweb.pl 2009-06-02 14:56:24.386441304 -0400
+***************
+*** 49,57 ****
+
+ # Connect to the database
+ END { $dbh->disconnect() if ($dbh); }
+! our $dbh = DBI->connect("dbi:mysql:database=$ENV{'db_name'}:host=$ENV{'db_server'}",
+! $ENV{'db_login'},
+! $ENV{'db_password'});
+ unless ($dbh) {
+ print header(),
+ "Cannot connect to database: $!\n\n";
+--- 49,57 ----
+
+ # Connect to the database
+ END { $dbh->disconnect() if ($dbh); }
+! our $dbh = DBI->connect("dbi:mysql:database=$ENV{'DB_NAME'}:host=$ENV{'DB_SERVER'}",
+! $ENV{'DB_LOGIN'},
+! $ENV{'DB_PASSWORD'});
+ unless ($dbh) {
+ print header(),
+ "Cannot connect to database: $!\n\n";