summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/trunk/mp_all.sh
diff options
context:
space:
mode:
authorNathan Harris <nharris@eoimaging.com>2009-07-17 17:41:55 (GMT)
committerNathan Harris <nharris@eoimaging.com>2009-07-17 17:41:55 (GMT)
commit1b9eeb6d26aaf407a2366810437b1ba09c1658b3 (patch)
treeced5a7243be006169b1bc46527366c975a012d99 /abs/core-testing/mythtv/trunk/mp_all.sh
parentdfc018de02274ae8d209e56f83c6f247f0731afe (diff)
downloadlinhes_pkgbuild-1b9eeb6d26aaf407a2366810437b1ba09c1658b3.zip
linhes_pkgbuild-1b9eeb6d26aaf407a2366810437b1ba09c1658b3.tar.gz
linhes_pkgbuild-1b9eeb6d26aaf407a2366810437b1ba09c1658b3.tar.bz2
mythtv-svn: updated to 20936
Diffstat (limited to 'abs/core-testing/mythtv/trunk/mp_all.sh')
-rwxr-xr-xabs/core-testing/mythtv/trunk/mp_all.sh13
1 files changed, 12 insertions, 1 deletions
diff --git a/abs/core-testing/mythtv/trunk/mp_all.sh b/abs/core-testing/mythtv/trunk/mp_all.sh
index 3b0421c..9f94859 100755
--- a/abs/core-testing/mythtv/trunk/mp_all.sh
+++ b/abs/core-testing/mythtv/trunk/mp_all.sh
@@ -1,5 +1,5 @@
#!/bin/sh
-_svnver=20787
+_svnver=20936
# NOTE: Make sure to build and install mythtv first BEFORE building anything else
buildlist=('mythtv' 'mytharchive' 'mythbrowser' 'mythflix' 'mythgallery' 'mythgame' 'mythmovies' 'mythmusic' 'mythnews' 'mythvideo' 'mythweather' 'mythzoneminder' 'mythweb' 'myththemes' 'morethemes')
@@ -9,9 +9,20 @@ for i in `echo ${buildlist[@]:0}`
do
echo "---------- building $i ----------"
cd ./$i
+
+ # set svn version in the PKGBUILD
+ sed -i s/^pkgver=.*/pkgver=$_svnver/ PKGBUILD
+
+ # optionally clean up for virgin build
+# rm -rf pkg src
+
+ # make the package
mp -f -i --holdver || exit 1
+
+ # clean up afterwards
rm -rf pkg
rm -f *~
+
cd ..
done