summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/trunk/mytharchive/PKGBUILD
diff options
context:
space:
mode:
authorNathan Harris <nharris@eoimaging.com>2009-02-08 22:20:20 (GMT)
committerNathan Harris <nharris@eoimaging.com>2009-02-08 22:20:20 (GMT)
commitd2cbfc286c25f31f20433e9149a0e62c4aaf900f (patch)
treedf940ae978797d62f346f465b91736b45d096649 /abs/core-testing/mythtv/trunk/mytharchive/PKGBUILD
parent7ee47af1a90327ecdd7ff9d790f2022545366b55 (diff)
downloadlinhes_pkgbuild-d2cbfc286c25f31f20433e9149a0e62c4aaf900f.zip
linhes_pkgbuild-d2cbfc286c25f31f20433e9149a0e62c4aaf900f.tar.gz
linhes_pkgbuild-d2cbfc286c25f31f20433e9149a0e62c4aaf900f.tar.bz2
The new structure... does not work yet.
Diffstat (limited to 'abs/core-testing/mythtv/trunk/mytharchive/PKGBUILD')
-rw-r--r--abs/core-testing/mythtv/trunk/mytharchive/PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/abs/core-testing/mythtv/trunk/mytharchive/PKGBUILD b/abs/core-testing/mythtv/trunk/mytharchive/PKGBUILD
new file mode 100644
index 0000000..4d3e179
--- /dev/null
+++ b/abs/core-testing/mythtv/trunk/mytharchive/PKGBUILD
@@ -0,0 +1,41 @@
+pkgname=mytharchive-svn
+pkgver=16153
+pkgrel=3
+pkgdesc="MythTV plugin that lets you create DVDs from or archive your recorded shows."
+arch=('i686')
+url="http://www.mythtv.org"
+license=('GPL')
+depends=('mythtv-svn' 'libxmu' 'mysql-python' 'pil' 'dvdauthor')
+source=()
+conflicts=('mythtv-plugins-svn')
+groups=('mythtv-all-plugins-svn')
+_svntrunk=http://cvs.mythtv.org/svn/trunk/mythplugins
+_svnmod=mythplugins
+
+
+build() {
+ PLUGIN=mytharchive
+ cd $startdir/src/
+ svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+ cd $startdir/src/mythplugins
+
+ PLUGIN=mytharchive
+ grep -q programs-libs.pro $PLUGIN/$PLUGIN/$PLUGIN.pro
+ if [ $? != 0 ]
+ then
+ echo "include ( ../../programs-libs.pro )" >> $PLUGIN/$PLUGIN/$PLUGIN.pro
+ msg "appending program lib"
+ fi
+ msg "Correcting configure kde3 to kde"
+ sed -i 's#kde3#kde#' configure || return 1
+ make distclean
+ ./configure --enable-opengl --disable-all --enable-create-archive --enable-create-dvd --enable-mytharchive || return 1
+ qmake mythplugins.pro || return 1
+ make qmake || return 1
+ msg "Correcting Makefile kde3 to kde"
+ sed -i 's#kde3#kde#' ./mytharchive/mytharchive/Makefile || return 1
+ make -j 2 || return 1
+ make INSTALL_ROOT=$startdir/pkg install
+}
+
+