summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/trunk/plugins/mythflix/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2008-12-11 01:37:12 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2008-12-11 01:37:12 (GMT)
commit54e39512d743caf5afe2f587536135c450ea4fcf (patch)
tree22e7ba4ba242782064d36d7a3828b01800436d38 /abs/core-testing/mythtv/trunk/plugins/mythflix/PKGBUILD
parent8417e5e3b118ed9e12563a3d4fceeb38b9e73d4f (diff)
parent42129857874c470c65d3b1dcb4bf42945a98dcfa (diff)
downloadlinhes_pkgbuild-54e39512d743caf5afe2f587536135c450ea4fcf.zip
linhes_pkgbuild-54e39512d743caf5afe2f587536135c450ea4fcf.tar.gz
linhes_pkgbuild-54e39512d743caf5afe2f587536135c450ea4fcf.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Conflicts: abs/core-testing/LinHES-config/LinHES-release
Diffstat (limited to 'abs/core-testing/mythtv/trunk/plugins/mythflix/PKGBUILD')
-rw-r--r--abs/core-testing/mythtv/trunk/plugins/mythflix/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/abs/core-testing/mythtv/trunk/plugins/mythflix/PKGBUILD b/abs/core-testing/mythtv/trunk/plugins/mythflix/PKGBUILD
new file mode 100644
index 0000000..9e8c92e
--- /dev/null
+++ b/abs/core-testing/mythtv/trunk/plugins/mythflix/PKGBUILD
@@ -0,0 +1,34 @@
+pkgname=mythflix-svn
+pkgver=16153
+pkgrel=2
+pkgdesc="Netflix access plugin for MythTV"
+url="http://www.mythtv.org"
+arch=('i686')
+depends=('mythtv-svn')
+conflicts=('mythtv-plugins-svn')
+groups=('mythtv-all-plugins-svn')
+license="GPL"
+source=()
+_svntrunk=http://cvs.mythtv.org/svn/trunk/mythplugins
+_svnmod=mythplugins
+
+
+build() {
+ cd $startdir/src/
+ echo svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+ svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+ cd $startdir/src/mythplugins
+ PLUGIN=mythflix
+ grep -q programs-libs.pro $PLUGIN/$PLUGIN/$PLUGIN.pro
+ if [ $? != 0 ]
+ then
+ echo "include ( ../../programs-libs.pro )" >> $PLUGIN/$PLUGIN/$PLUGIN.pro
+ msg "appending program lib"
+ fi
+ make distclean
+ ./configure --disable-all --enable-opengl --enable-mythflix
+
+ make -j 2 || return 1
+
+ make INSTALL_ROOT=$startdir/pkg install
+}