summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/trunk
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-03-21 19:58:57 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-03-21 19:58:57 (GMT)
commit98169e32bb1ceb02382a0eb23e9444a28d51c1bc (patch)
treea81482db8af2fe37e6f87f8bfe7740b4295918d5 /abs/core-testing/mythtv/trunk
parenteb21cdae644a7758d77f5a9bfe6b42ef4291266e (diff)
downloadlinhes_pkgbuild-98169e32bb1ceb02382a0eb23e9444a28d51c1bc.zip
linhes_pkgbuild-98169e32bb1ceb02382a0eb23e9444a28d51c1bc.tar.gz
linhes_pkgbuild-98169e32bb1ceb02382a0eb23e9444a28d51c1bc.tar.bz2
mythtv: modify pretty script to check for mythlink or mythrename
closes 637 Note only made the change to pretty, did not rebuild pkgs
Diffstat (limited to 'abs/core-testing/mythtv/trunk')
-rwxr-xr-xabs/core-testing/mythtv/trunk/mythtv/PKGBUILD5
-rwxr-xr-xabs/core-testing/mythtv/trunk/mythtv/pretty11
2 files changed, 15 insertions, 1 deletions
diff --git a/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD b/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
index 2a6f2a4..8d27f31 100755
--- a/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
@@ -89,3 +89,8 @@ build() {
install -m0755 $startdir/src/pretty $startdir/pkg/etc/cron.hourly/
}
+md5sums=('7ef6de58240e7aad389a0b13d91b1cf6'
+ '2babd4b8e146a7538d18dcd55695b0be'
+ 'f735805a80b0d1180dee01f9df1b7004'
+ 'f407d6af23e74a49540755420f84fa58'
+ 'f944c51c40208fdb3d8e3dd3d8c60bf3')
diff --git a/abs/core-testing/mythtv/trunk/mythtv/pretty b/abs/core-testing/mythtv/trunk/mythtv/pretty
index 1cfc57b..8b0e051 100755
--- a/abs/core-testing/mythtv/trunk/mythtv/pretty
+++ b/abs/core-testing/mythtv/trunk/mythtv/pretty
@@ -1,2 +1,11 @@
#!/bin/bash
-su - mythtv -c "perl /usr/share/mythtv/contrib/user_jobs/mythrename.pl --link /myth/pretty"
+#!/bin/bash
+if [ -f /usr/share/mythtv/contrib/user_jobs/mythlink.pl ]
+then
+ su - mythtv -c "perl /usr/share/mythtv/contrib/user_jobs/mythlink.pl --link /myth/pretty"
+elif [ -f /usr/share/mythtv/contrib/user_jobs/mythrename.pl ]
+then
+ su - mythtv -c "perl /usr/share/mythtv/contrib/user_jobs/mythrename.pl --link /myth/pretty"a
+fi
+
+