summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verison.net>2010-03-29 23:44:06 (GMT)
committerMichael Hanson <hansonorders@verison.net>2010-03-29 23:44:06 (GMT)
commit7eb55688e5889217f277f5153bbb65a556fad7e5 (patch)
tree15805e6aabba36634b21b933ef8845fe30f803a6 /abs/core-testing/mythtv
parentea959df99225935b744e6abaac34db428857481c (diff)
parent5dfeda318a5b6725cf441cc936ace916448baf79 (diff)
downloadlinhes_pkgbuild-7eb55688e5889217f277f5153bbb65a556fad7e5.zip
linhes_pkgbuild-7eb55688e5889217f277f5153bbb65a556fad7e5.tar.gz
linhes_pkgbuild-7eb55688e5889217f277f5153bbb65a556fad7e5.tar.bz2
Merge branch 'master' of mihanson@knoppmyth.net:LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/mythtv')
-rw-r--r--abs/core-testing/mythtv/stable-0.22/mythsmolt/PKGBUILD9
-rw-r--r--abs/core-testing/mythtv/stable-0.22/mythsmolt/smolt_init_login.sh39
2 files changed, 44 insertions, 4 deletions
diff --git a/abs/core-testing/mythtv/stable-0.22/mythsmolt/PKGBUILD b/abs/core-testing/mythtv/stable-0.22/mythsmolt/PKGBUILD
index e609048..d970cd9 100644
--- a/abs/core-testing/mythtv/stable-0.22/mythsmolt/PKGBUILD
+++ b/abs/core-testing/mythtv/stable-0.22/mythsmolt/PKGBUILD
@@ -1,12 +1,12 @@
pkgname=mythsmolt
pkgver=0.22
-pkgrel=16
+pkgrel=26
pkgdesc="mythsmolt, a hardware profileing tool"
arch=('i686' 'x86_64')
url="http://www.mythvantage.com"
license=('GPL')
depends=("mythtv>=${pkgver}" urlgrabber python-simplejson)
-source=("http://www.mythvantage.com/request.php?4")
+source=("http://www.mythvantage.com/request.php?4" 'smolt_init_login.sh' )
groups=('mythtv-extras')
@@ -15,6 +15,7 @@ build() {
./configure.sh
make || return 1
make INSTALL_ROOT=$startdir/pkg install
+ install -D -m 755 $srcdir/smolt_init_login.sh $pkgdir/etc/profile.d/smolt_init_login.sh
}
-md5sums=('b8e9b79db0d8f428ba127c6e42577761')
-md5sums=('fdf68ec5c78827aefca6f09ad82296a4')
+md5sums=('fdf68ec5c78827aefca6f09ad82296a4'
+ '57a3416d90e59abbd5062436583c17e1')
diff --git a/abs/core-testing/mythtv/stable-0.22/mythsmolt/smolt_init_login.sh b/abs/core-testing/mythtv/stable-0.22/mythsmolt/smolt_init_login.sh
new file mode 100644
index 0000000..0b76305
--- /dev/null
+++ b/abs/core-testing/mythtv/stable-0.22/mythsmolt/smolt_init_login.sh
@@ -0,0 +1,39 @@
+if [ $UID = 0 -o $UID = 1000 ]
+then
+ INIT=`ps -p 1 -o comm=`
+ if [ x$INIT = xrunit ]
+ then
+ if [[ -f /home/mythtv/.configure && $- = *i* ]]
+ then
+ if [ ! -z "$PS1" ]
+ then
+ if [ $0 = "-bash" ]
+ then
+ if [ ! -e /home/mythtv/.mythtv/MythSmolt/hw-uuid ]
+ then
+ echo ""
+ echo "####################################################"
+ echo "It appears you have not yet run smolt"
+ echo "Please take the time to submit your hardware profile"
+ echo ""
+ echo "press any key to continue:"
+ echo "####################################################"
+ read a
+ mkdir -p /home/mythtv/.mythtv/MythSmolt
+ chown -R mythtv:users /home/mythtv/.mythtv/MythSmolt
+
+ if [ $UID = 0 ]
+ then
+ su mythtv -c "/usr/share/mythtv/mythsmolt/scripts/sendProfile.py" && su mythtv -c "touch /home/mythtv/.mythtv/MythSmolt/hw-uuid"
+ else
+ /usr/share/mythtv/mythsmolt/scripts/sendProfile.py && touch /home/mythtv/.mythtv/MythSmolt/hw-uuid
+ fi
+ fi
+ fi
+ fi
+ fi
+ fi
+fi
+
+
+