summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/nasm/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2008-12-01 23:48:10 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2008-12-01 23:48:10 (GMT)
commit575bd0829fce6f7582aefca086e1894b63812ef8 (patch)
tree1b66d798131ebd448034b30a2d7d6111aabf4c52 /abs/core-testing/nasm/PKGBUILD
parent466412d4bdf5beb0645eced2d064df5e15f9b76b (diff)
downloadlinhes_pkgbuild-575bd0829fce6f7582aefca086e1894b63812ef8.zip
linhes_pkgbuild-575bd0829fce6f7582aefca086e1894b63812ef8.tar.gz
linhes_pkgbuild-575bd0829fce6f7582aefca086e1894b63812ef8.tar.bz2
Emulators and deps.
Signed-off-by: Cecil Hugh Watson <knoppmyth@gmail.com>
Diffstat (limited to 'abs/core-testing/nasm/PKGBUILD')
-rw-r--r--abs/core-testing/nasm/PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/abs/core-testing/nasm/PKGBUILD b/abs/core-testing/nasm/PKGBUILD
new file mode 100644
index 0000000..b17bbf9
--- /dev/null
+++ b/abs/core-testing/nasm/PKGBUILD
@@ -0,0 +1,21 @@
+# $Id: PKGBUILD 18748 2008-11-08 22:48:50Z aaron $
+# Maintainer: Aaron Griffin <aaron@archlinux.org>
+# Committer: Judd Vinet <jvinet@zeroflux.org>
+
+pkgname=nasm
+pkgver=2.05.01
+pkgrel=1
+pkgdesc="80x86 assembler designed for portability and modularity"
+url="http://nasm.sourceforge.net"
+license=('LGPL')
+arch=('i686' 'x86_64')
+depends=('glibc')
+source=(http://downloads.sourceforge.net/nasm/nasm-${pkgver}.tar.bz2)
+md5sums=('da4977f6d9d9b8f00527f2c62109453b')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr || return 1
+ make || return 1
+ make INSTALLROOT=${pkgdir} install || return 1
+}